1

In our SharePoint 2013 site we have custom theme aware CSS, most of which is working fine across browsers (IE8/9/10, Safari and Firefox) but in case of
/* [ReplaceColor(themeColor:"SelectionBackground")] */ background-color:rgba( 156,206,240,0.5 )
IE8 is not rendering the background style to the style sheet and hence no background color on selection is applied.
Can some one please suggest possible cause/resolution to this issue.

PS - I m new to SharePoint 2013 theme engine.

1

I don't have a virtual machine with IE 8 at my disposal right now, but according to http://caniuse.com/css3-colors IE 8 does not support RGBa color values. Looks like you have to resort to a HEX value for IE 8 and below.

UPDATE ** To get something going in IE 8, you could use the MSFT opacity filter like this:

body
{
/* [ReplaceColor(themeColor:"SelectionBackground")] */ background-color:rgb( 156,206,240)
  filter: alpha(opacity=50);
  -ms-filter: alpha(opacity=50);
}

It will be ignored by all modern browsers (including IE 9 & 10) except IE 8 and below.

  • Agree with you Sig, IE8 wont support RGBa and after bit of searching I found here stackoverflow.com/questions/3975688/… that opacity wont work in IE8. – bkk May 17 '13 at 11:44
  • IIRC, for IE8 you could try the MSFT proprietary filter property. See my updated answer. – Sig Weber May 17 '13 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.