Yes this question is the same as :

This question

How ever none of the proposed solutions work for me.

  • I've tried swapping the account in Central Admin (did not work)
  • I've created a new AD account, gave it all of admin permissions and added the account to central admin and as the site collection admin for the target site

When I try deploying an app with the new account I get this error : "To interact with SharePoint projects in Visual Studio, your system user account must have administrative privileges"

The user does.. have the privileges, I've added the user to the "Administrators" group as well as the "WSS_ADMN_WPG" group for write access to system resources used by SharePoint Foundation.

I've been battling with this issue for quite some time and could really use some assistance. Please help

I thank you in advance.


Here's how I've set up the accounts:

  • Farm Admins : Domain Admin, Account 1, Account 2, Builtin Admin
  • Farm Service Account : Account 2
  • Site Collection Admin : Domain Admin (target site)

Is there something wrong with the above? Right now, the central administration site doesn't log me in as System Account but the site collection does! Please help :( This error is a huge road block.

  • @RobertLindgren um when I run as administrator I get the first error "System account cannot perform this action." This is why I am trying to deploy/install app using a different account. Is there no way to give the other account full admin privileges?
    – anpatel
    Commented May 16, 2013 at 18:13
  • @RobertLindgren yes, I am running into problems making use of those tips. Maybe I read it wrong, but it asks me to create a new account and deploy/install the app using the new account, which is what I am attempting to do. I've also tried swapping the farm service account and it did not work either.
    – anpatel
    Commented May 16, 2013 at 18:22
  • I think the problem is that your user account is both farm admin and the account you are running visual studio with Commented May 16, 2013 at 18:24
  • @RobertLindgren Alright I've tried to set the farm admin account as AccountA and I ran Visual Studio with AccountB, but still no avail, I get the first error
    – anpatel
    Commented May 16, 2013 at 18:32
  • @RobertLindgren I've updated my question, please have a look and let me know what you think
    – anpatel
    Commented May 16, 2013 at 21:56

4 Answers 4


I fixed the issue by creating a new web application under a new account from central administration and creating my target site collection under the new web application.

For the site collection the primary administrator was the new account and the secondary administrator was the domain administrator account that I would be using in Visual Studio to deploy my app. After this it was smooth sailing.

I hope this helps others. It was a fairly straight forward solution that just took a while for me to arrive at.

Pardon my ignorance, I am fairly new to SharePoint Development


Is that issue resolved?

In my case, i had just login to server with different account and open VS with farm account and then try to deploy it. It deployed successfully!

Don't know the proper reason but it's work.

  • 1
    what do you mean by "open VS with farm account" @ajeet
    – Umer Khan
    Commented Aug 10, 2017 at 9:55

I had this problem too. What I did was take my Sharepoint admin permissions off my account and made myself the developer site admin (where I would be deploying the Add-in). That worked.


create another user like AppDeveloper in active directory and provide site collection administrator permissions in site

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.