0

I have a powershell script that does the following:

  1. Create web application x
  2. Add and install some wsps
  3. Create site collection using a site definition deployed with one of the wsps. 3b. The definition activates some features along with one that provisions some new managed metadata fields.

However when I use any of the fields as columns in a list or library they are always disabled. I know I need to activate the TaxonomyFieldAdded feature before I provision my own fields and I've tried this in several ways:

  1. Placed the feature id in in the onet.xml file at the top before the feature that provisions my fields.
  2. Specify that my feature depends on the TaxonomyFieldAdded feature (while also specified on the onet.xml file).
  3. Specify that my feature depends on the TaxonomyFieldAdded feature (while not specified on the onet.xml file).
  4. Activating the feature in the FeatureActivated event receiver before I finish provisioning fields in my Fields feature.

None of the above has worked. The strange thing is that if I create the site collection from Central Admin the fields work fine. Also if I delete and create the site collection again (while keeping the wsps and the web application) through powershell it also works. Can anyone help me find out what is going on here?

Edit: I've used this guide to create my fields: http://www.sharepointconfig.com/2011/03/the-complete-guide-to-provisioning-sharepoint-2010-managed-metadata-fields/

Edit2: Although I could be wrong I don't believe the field definitions themselves are the problem. They are set up almost exactly (apart from names and guids) according to the example in my link and they work as long as I create Site Collections through Central Admin, but not through the initial powershell.

Edit3: Creating new managed metadata fields works fine so there must be something with the order of events.

1

There is a lot to think about when provisioning a taxonomy field.

For example. You need to make sure TaxonomyFieldAdded feature is activated (as you do)

But also you need to provision a field of type Note that is bound to your taxonomy field.

And lastly, you need to connect your field to a TermSet to be able to use it.

This link is of great help to me when creating new Taxonomy Fields (though not through powershell): http://www.sharepointconfig.com/2011/03/the-complete-guide-to-provisioning-sharepoint-2010-managed-metadata-fields/

  • I was just about to add that I've followed the example you linked to. The field definitions work though, just not when I provision through PowerShell. – Thomas May 7 '13 at 11:05
0

In central admin, did you check to make sure your managed metadataservice is attached to your web application? Go to central admin /_admin/WebApplicationList.aspx. select the web application and click the "Service connections" in the ribbon. make sure you meta data service is "checked".

If it is, then go to the actual metadata service and check to see if it is active.

You can also start and stop the meta data service in the /_admin/Server.aspx (services in the farm).

  • The web application uses the default connections which ticks every box so it should be connected. I have tried stopping and restarting the managed metadata service before creating the site collection and that had no effect. – Thomas May 8 '13 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.