We have numerous custom web parts that use XML to pull in RSS feeds. The feeds stopped coming in about 2 weeks ago. We are not sure exactly what caused this, but there was an admin who was working on a sub-site at the time it stopped working ... I'm guessing it has something to do with permissions because I know she was messing with them.

I have tried all the basics ... resetting IIS, enabling anonymous access to the entire site, restoring web.config, confirmed URL of feed is correct and non-auth, and removed proxy tags in web.config though it was already set to disabled.

  1. 1 of the webparts simply does not update any info from the feed. It's stuck on April 22nd, 2013
  2. Another webpart pulls from an internal SP list, and does not get any results.
  3. Another webpart that should be pulling data from a feed gives this error "One or more field types are not installed properly. Go to the list settings page to delete these fields."

I checked logs in the 12 hive and have seen the following error:

  • 05/02/2013 12:38:13.54 w3wp.exe (0x1748) 0x171C SharePoint Portal Server WebParts 8imj Unexpected Exception in RssAggregatorWebPart::OnPreRender... System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary. at System.ThrowHelper.ThrowKeyNotFoundException() at System.Collections.Generic.Dictionary`2.get_Item(TKey key) at Microsoft.SharePoint.Portal.WebControls.RSSAggregatorWebPart.OnPreRender(EventArgs e)

Upon Googling this error, most people fixed it by either removing the proxy tag from the web.config, or enabled anon access. Neither of those fixes worked for me.

Any help would be greatly appreciated!

  • Before anyone takes the time to answer this question, please hold off for now.... I may have figured it out: Went on the WFE to download File Monitor, and it was not able to reach the page in IE. I cannot reach any page due to Local Access only. No Internet means no RSS :) I am working with our network admins to resolve this issue before I continue, but I'm pretty sure this will solve it. Thanks! – Aaron May 6 '13 at 20:56

The problem turned out to be a firewall issue. There was an IP that was ONE number off, and it broke our connection to the outside world .. hence, no RSS. :)

  • Thanks for the update and solution to the problem - I have closed the question because it turned out to be a specific problem related to your environment. – SPDoctor May 8 '13 at 21:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.