0

I am trying to upload files, larger than 30Mb but for some reason SP does not finish these uploads. I uploaded a 27.6 MB file with no problem. I have googled already quite a bit and updated the config in the admin console to actually allow 2000 MB max upload. However the upload still failes. Any ideas? We are using SP 2007.

1

you need to increase the default chunk size in stsadm

To set the large file chunk size to 1,073,741,824 bytes (1024 MB), use the following syntax:

stsadm -o setproperty -pn large-file-chunk-size -pv 1073741824

To view the current setting of the large file chunk size property, use the following syntax:

stsadm -o getproperty -pn large-file-chunk-size –url http://server_name 

the number is bytes, that number should be more than enough!

Specifies the amount of data that can be read from the server running Microsoft SQL Server at one time.

To determine the chunk size that is read, you divide the file size by the current chunk size setting. The chunk size is not related to the maximum upload file size. The chunk size simply specifies the amount of data that can be read from a file at one time. For example, if you have a file that is 73,400,320 bytes in size and your current chunk size is set to 5,242,880 bytes, the file would be read in 14 chunks (73,400,320/5,242,880).

the above solution should solve your issue if you have setup the web.config to a good time and setup the max file size.... which i belive you have :)

http://technet.microsoft.com/en-gb/library/cc288521(v=office.12).aspx

| improve this answer | |
0

The default limit should be 50 MB

Here is a really good guide from MSDN blogs that helsp you condigure IIS timeouts and other useful stuff to increase the maximum filesize

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.