I am a newbie when it comes to server configuration and maintenance. I installed a copy of SharePoint 2013 for evaluation purposes and got everything up and running okay, but have run into issues installing/configuring the 2013 workflows.

I have followed all of the instructions here: http://technet.microsoft.com/en-us/library/jj658588.aspx and have also reviewed several other blogs and instructions to try and answer my question, but have had no luck.

I am able to install the Workflow Management Site with no issues, but I run into a problem when I try and "register" the workflow to the site collection using the Register-SPWorkflowService cmdlet.

Here is the cmdlet I am running:

Register-SPWorkflowService -SPSite "" -WorkflowHostUri "http://workflow." -AllowOAuthHttp

Here is a portion of the error I am receiving:

Register-SPWorkflowService : A response was returned that did not come from the Workflow Manager. Status code = 401: HTTP headers received from the server - WWW-Authenticate: Negotiate,NTLM.

So obviously I am seeing here that there is an authentication problem, but after dozens of google searches I am not finding anything that specifically speaks to authentication errors while running this cmdlet.

I am totally at a loss and have spent more than a day working on this. Thank you in advance for your help! :)

2 Answers 2


You need (1) SharePoint 2013 farm installed & configured (looks like you have that) and (2) a Workflow Manager 1.0 farm installed & provisioned. Once you do that, you then run the PowerShell cmdlet in your post.

For the -SPSite attribute, you need to point to a valid SharePoint site collection.

For the -WorkflowHostUri, you need to point to the address of your workflow farm which you can get by running the PowerShell cmdlet Get-WFFarm from the Workflow Manager PowerShell... that will tell you the name of the endpoint as well as the port you can use (12291 is for HTTP).

Make sure your farm is current too... I have two posts on this (http://www.andrewconnell.com/blog/Updates-For-SP2013-Workflow & http://www.andrewconnell.com/blog/Workflow-Improvements-Changes-SP2013-March-PU-and-RTM-Developer-Tools). If you happen to have a subscription to Pluralsight, my workflow course (http://pluralsight.com/training/Courses/TableOfContents/sharepoint2013-workflow-fundamentals), specifically module 2 shows how to do this as does a recent series by Spence Harbar (http://www.harbar.net/articles/wfm2.aspx).

I'm not trying to get traffic, just providing resources. Feel free to follow up if you are still having issues.


I am not sure what you wanted to say by


but if you really added not only server name, but also "workflow" before it that could be the cause of the issue. Also, try to add "-Force" parameter at the end.

  • Hi @MikhailSP, Thank you for the response! I also was confused where the "workflow" came in, but every example I found online included the 'workflow' before the domain. I tried removing it and I get a 400 "Bad Response" error instead of an "Authorization" error. I also tried using the -Force parameter per your suggestion, but received the same error. May 2, 2013 at 20:22
  • 1
    If you are using IP address of the server instead of its name, try to use its name. If it doesn't help, please provide us the full error mesage, please.
    – MikhailSP
    May 2, 2013 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.