I have an out-of-the-box document list that is created in dev and have the Document ID Service feature activiated. All works well.

My test server has the Document ID Service enabled and document librarys with added documents get assigned proper doc ids, all works well.

But the problem is when I export a library from dev using Export-SPWeb and import into test using Import-SPWeb any new documents added to that library will not get document IDs assigned anymore? I tried on test restarting the "Doc ID" Feature and running the two timer jobs, but no good. Only the librarys that were NOT imported are working on test.

Thanks for any help.

2 Answers 2


A list item could instruct the Document Id feature NOT TO re-generate its Identifier - this is controlled by a property known as PersistID column (column is hidden, does not render in views either - you would need a SharePoint Manager 2010 to look at it). Usually during move operations, SharePoint Server 2010 keeps the document ID, and only copy operations SharePoint Server 2010 regenerate new document ID (is a simple matter of how attached Event Receivers are performing, differently in Move vs. Copy operations).

Did you had a look at this?? Try setting it to False and during next execution of the "Document ID assignment job" it should regenerate.

I'm not sure if the actual Export-Web does forbid the handlers to run simply.

  • Thanks for your response, I found the issue is when importing a list the Document Value column is copied over but the four "Document ID Generator" EventReceivers arent' So when the "Document ID" feature is enabled, it sees the fields exist on the list but doesnt bother to add the missing event receivers because the document value field exists.
    – NYTom
    Commented Apr 30, 2013 at 18:43

What I wound up doing since the "Document ID Generator" events (4 of them) don't get copied over on an export/import was I added the declaration of the 4 EventReceivers in the Elements.xml file of my feature and its now working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.