I am running the Workflow Manager Configuration Wizard for Sharepoint 2013 workflows, but I am getting the flowing errors, I can't find anything on Google so I am hoping that someone here knows what to do?

Error 1: Port Number 9355 specified for HTTPS port is blocked

Error 2: Port number 9002 specified for Internal Communication Port Range is blocked.

enter image description here



Problem resolved after I stop those Windows Services! -

  • Service Bus Gateway
  • Service Bus Message Broker
  • Windows Fabric Host Service
  • This didn't work for me. – PeterX Aug 19 '13 at 3:33
  • 1
    Problem resolved after I stop those Windows Services! - Service Bus Gateway Service Bus Message Broker Windows Fabric Host Service The Solution Helped me :) – Qasim AlQaru Dec 18 '13 at 12:23
  • Worked. Make sure to restart the configuration manager. Simple going back and trying to configure will not work. – Muhammedh Sep 3 '15 at 8:41
  • Take note of the poster's comments. you have to STOP those services and not restart them. After I STOPPED them, everything was fine. – Fox Dec 1 '15 at 8:34
  • Note this is the same as running Stop-SBHost in PowerShell – Chris Odegard Dec 27 '18 at 18:57

It works for me. I would like to notice that you should restart the configuration at the begining. if you did just a refresh (by clicking on a refresh button provided), it doesn't work.


As per my post here, I:

  • Installed Service Bus and Workflow Manager Cumulative Updates on all servers (using the Web Platform Installer - be careful, it might reboot servers without warning!)
  • Left the farm on the App Sever and created a new one using custom settings (had to specify another database name)
  • The WFE's seemed to be in an inconsistent state: the Workflow Manager UI had 4 options (Create, Create [Custom], Join, and Leave). This was weird so I "left" the invalid farm (maybe it thought it had its own?). Then I joined with the new database names.


  • Originally the URL's were HOSTS entries and are now A Records. (Not sure if possible cause).
  • Make sure you specify the correct account (I used Farm account - but it wanted to default to install account). Powershell commands failed with "access denied" but UI worked.
  • Double-check your proxy settings.

That happened to me too. The thing was that I already made a web application with the port number 9000. So you have to choose "Advanced settings" and set "Internal communication port range" to a new range. (For example: 8000).

That solved my problem.


Check your firewall settings and Disable any port listening whilst you are doing the install. You can Enable the rule again once you have completed the install. You will need to do this for both the Inbound and Outbound Rules. Hope this helps. Firewall Rules

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.