In my List Workflow I've updated some of the properties of an Initiation Parameter, including the description that's visible in the form.

According to the workflow settings for the Library the workflow version changes when I publish yet the Initiation Form fails to reflect these new changes. When I return to the Workflow in SPD2010 I can see the changes I made in the Initiation Parameter section.

Am I missing a critical step? Is this a flaw in SPD? I've tried opening the initiation form in InfoPath 2010 to save and publish with no differing results.

Please advise.

Edit May 1, 2013: If there's a possible way to remove the old initiation parameters/form and create them anew I would be open to this as well.

2 Answers 2


You should edit the Workflow via SharePoint Designer 2010, under workflow properties you should find FORMS and there you should have the Initiation form. Opening that for editing should force re-reading parameters and update it.

Did you actually tried that?

  • Yes, I have tried this. I opened the form in InfoPath2010 and saved, re-published. There's no change in the initiation form. I can see by viewing the Workflow.xoml.config.xml that the structure of the initiation paramters has indeed changed; I see my changes in the xml. The form, supposedly created dynamically when the workflow is initiated, doesn't change. I'm really stumped.
    – adnauseam
    Commented Apr 30, 2013 at 14:51
  • you should attempt to clean SPD cache, use sharemyp0int.blogspot.de/2011/01/… and try opening again. Commented Apr 30, 2013 at 16:29
  • I have just tried this with the same results. The content of the files is the same; I can see the changes I've made in the initiation parameters. The changes still do not propagate down to the Initiation Form. Is there a way I can scrap the initiation parameters and the initiation form and just start again?
    – adnauseam
    Commented May 1, 2013 at 14:40

It seems as though my own meddling may have detached the form from the workflow. I admit, I was poking around in InfoPath and could have saved/published a change I didn't understand. This resulted in the form being de-linked from the Workflow itself.

The solution was to recreate the workflow under a different name, remove the old one, and publish again. The result is that changes to the Initiation Parameters are now seen in the initiation form.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.