I made a reusable workflow in Sharepoint Designer and checked that it's working in a site.

Then I saved it as a template, downloaded it from the site assets, uploaded to a new site. Even after activating its feature, the workflow is nowhere to be seen... I can't associate it to any list or document library because of that. It doesn't even show in Sharepoint Designer.

EDIT importing it to Visual Studio, then deploying from there, causes the workflow to be deployed, but not published. How can I make it so that it's automatically published? Also, if I do publish it via Sharepoint Designer, I can't associate it to any list or content type. It gives an error that has to do with the rendering of an asp.net control in the association page.

I have seen someone else with the same problem, and his question was answered. But in my case both sites are in the same language (en-us), and even so deleting the resource file doesn't solve it.


P.S.: I can only deploy from Visual Studio if I delete the workflows list instance from the solution. Otherwise it fails, due to a conflict with the existing workflows list, which VS just can't solve. That happens even in a new, empty site. Am I doing something wrong here?

  • Stupid me. I had to include the workflow list instance for it to work. I couldn't add it due to some issues caused by a broken deployment. Once I fixed it, the workflow appeared correctly and I could use it.
    – Geeky Guy
    Commented Apr 26, 2013 at 18:29
  • can you elaborate on: "include the workflow list instance"?
    – Jo Sevigny
    Commented Jul 22, 2013 at 23:04
  • There is a built in list called "Workflows" that comes with Sharepoint. For some reason you have to overwrite it in order to include your workflows. At least that's how it has worked for me so far.
    – Geeky Guy
    Commented Jul 23, 2013 at 12:08


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.