2

I have created a sharepoint list in 2013 by importing an access 2013 table which has 7414 records and have set the list to sync with the table held on my local PC. I want to start over again but when I try to show the list on my sharepoint site I get error message "the the list exceeds the 5000 limit" and I am unable to show it. How can I overcome this? I have full owner permissions. Graham

3

Owner permissions are not enough. You need to either have a Site Collection Administrator delete the list or find out when the Large List Threshold Window is for your organization and delete it then.

Alternatively, you might be able to create a view that shows less than 5000 items, then use the DataSheet view to bulk delete until the list total is below 5000. This probably won't work as you will likely hit the same error trying to create the view but it is worth a shot.

2

link to the sharepoint list with MS-Access (2007 is good enough) and just run a query 'delete * from table' and then let it run and go for coffee ....This link through MS_Access does not appear to be limited by the view threshold (also not for displaying the contents of a list)

The actual deletion is slow (in my case just a few rows per second) and deleted rows go to recycle bin but you only need to run the query, no further interaction required.

  • This was great and saved me! Need to note that this will work, but must be in "Linked Table" mode -- can't do it by exporting to a table within your Access DB, then expect to Export back to the same table -- it will just append "_1" to the name and create a new, blank list (ran into that while attempting this). Note, though - I wasn't using the Office 365 version, so I don't know if this answer would've helped him or not, but it definitely works with Access 2013 and SharePoint 2013. – vapcguy Nov 11 '15 at 2:06
0

Resource Throttling "List View Threshold" property limits the maximum number of items that a database operation can involve at one time. It is 5000 by default. You can change it in:

Central Administration -> Manage Web Applications -> Select WebApp -> General Settings/Resource Throttling -> Change "List View Threshold".

0

as mentionned here: http://norpoint.wordpress.com/2012/07/12/change-or-disable-throttling-settings-for-large-sharepoint-lists/

for a one-time job it could be easier to just do

$web = Get-SPWeb $webUrl
$web.AllowUnsafeUpdates = $true
$list = $web.Lists[$listName]
$list.enablethrottling = $false
$list.update()
$list.delete()

it worked for me :)

0

You must be a Farm Administrator AND have Administrator rights in your SharePoint Server to see your list.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Waqas Sarwar MVP Aug 1 '14 at 18:53
  • I don't understand your comment, this provide a solution for the user, if he has Administrative privileges on SharePoint and Windows Server, he can see and delete the items. – Victor Martins Aug 4 '14 at 16:21
0

Switch to "Data Sheet" select all the rows but don't use ctrl + A. select all the row cells in any columns -> right click -> Delete Rows.

Again this takes a bit of time but does the job!

0

I've been trying to find a solution for this... and I am posting this answer if it could help anyone...

Sharepoint lists and Microsoft access are integrated very well..

  1. Open Access
  2. Under Create Tab---> Sharepoint List---> Existing sharepoint list
  3. In the URL---> Paste your site link
  4. Select the list you want to delete (The one with moer than 5000 items
  5. Click ok. Now there will be a connection between sharepoint and access
  6. The list table will not be populated in Access. Open the table---> Select all the records (CTRL +A) and then hit delete...
  7. Once done... you can break the link between access and sharepoint by converting table in access to a normal table

Hope this helps!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.