Every time I click on a excel file I am receiving a popup message mentioning -

We're sorry. We ran into a problem completing your request

MS Word is working fine though.

I performed all the steps mentioned in the below given articles:

Am I missing anything?


I found the solution.. This is what I did -

Navigate to Document Library -> Library Settings -> Advanced Settings -> and changed the 'Default open behavior for browser-enabled documents:' to 'Open in the client application'.

and Excel sheets worked smooth :)!

I tried the same issue on another server without enabling the excel services and all the other saga (two links mentioned in my question) and it worked fine.

I was able to check-out and check-in an excel file without any fuss. Can someone confirm this please?

  • 1
    Hey Muhammedh, I was looking for answer to this also, works like a charm. Thank you for posting and sharing. – user18922 Aug 14 '13 at 13:47
  • 1
    This solution is worked for me. thanks for sharing this tips. regards Shiva – user39255 Feb 2 '15 at 13:57
  • @shiva u are welcome bro :)! – Muhammedh Mar 31 '15 at 9:00

protected by Community Apr 28 '15 at 9:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.