0

I have created a Sql Reporting Services Report from a SharePoint list. I am creating this report in Microsoft SQL Server Report Builder.

When I hit "run query" on my dataset in the query designer, I get a full table of my expected results. However, when I set up a table or list and run the report, no data is shown as if it were an empty dataset.

To make things more confusing, this is a report that was actually working a few months ago, and neither the SharePoint list columns nor the report were changed in the time since the report was created. It was displaying the data correctly using a list control a few months ago, but now displays an empty page.

Has anybody seen an issue like this before? Thanks.

-1

If you are passing parameters check size of parameters

  • Where do User check the size of parameters, and how does user overcome this potential parameter size issue? Please expand your answer. Thanks. – Benny Skogberg Mar 6 '14 at 2:44
1

I experienced a similar issue when my list items were located in folders..the items appeared correctly on my query, but when I ran the report nothing displayed (I eventually had to create an XML data source instead of using the default SharePoint List data source). Not sure if you're list items were moved into folders, but wanted to provide the KM article in case this was the issue you faced: http://support.microsoft.com/kb/2826162

1

SSRS will only return items in the default view unless you create a filter parameter on the query itself. So if items are in folders or hidden from the default view your query wont pull them without this filter parameter.

Right click on the dataset then choose properties and add a parameter like Created > 1900-01-01 This should return everything in the list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.