1

I have windows server 2012 and sharepoint 2013 installed. Now i wanted to configured my wcf service on the server.

After Creating the new app pool & site its shows me the error as below
HTTP Error 500.19 - Internal Server Error

The configuration section 'system.serviceModel' cannot be read because it is missing a section declaration

Also i have found the solution on the link below HTTP Error 404.17 - Not Found

where suggested to run the command "servicemodelreg -i". I have did the same and my service started working. But i found the sharepoint services are stopped working showing the below error

Exception message:
Could not load type 'System.ServiceModel.Activation.HttpModule' from assembly 'System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

Please help me out to the resolve this problem.....

Thanks is advance

1

This error can occur when there are multiple versions of the .NET Framework on the computer that is running IIS, and IIS was installed after .NET Framework 4.0 or before the Service Model in Windows Communication Foundation was registered.

To register the correct version of ASP.NET you need type the following command at the commands prompt:

cd C:\Windows\Microsoft.NET\Framework64\v4.0.30319
aspnet_regiis.exe -iru
iisreset

More info

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.