I'm totally stuck trying to get the User Profile Synchronization Service to run in a new SharePoint 2013 system. I've followed every possible guide and applied every known fix, but it's still unable to start. I really don't know what else to do.


  • Single Active Directory domain; the NetBIOS name matches the first part of the domain FQDN.
  • Test system: a single server running Windows Server 2012, SQL Server 2012, SharePoint 2013.
  • WS 2012 is updated to latest patches; all system prerequisites are in place; SQL Server 2012 is updated to SP1; SP2013 is updated with the March 2013 update.
  • SharePoint is configured to connect to the DB using the NetBIOS name of the server (NOT the FQDN); WINS is operational in the network.
  • SharePoint is up and running, I can create and browse sites.
  • The User Profile Service is also up and running; MySites works fine.
  • The farm administrator account is in the local Administrators group on the test system.
  • Network DTC access is enabled.

When I try to start the UPSS, it doesn't work. The main (repeated) error in the event log is the dreaded .Net SqlClient Data Provider: System.Data.SqlClient.SqlException: HostId is not registered.

What I tried:

I'm really stuck and don't know what else to do.

  • Are you running some kind of Group Policy that impact the servers on your domain? Can you login as the farm account and open RegEdit? (I ask because I have seen cases where admin accounts can't access the registry.) I would run the ULS Log Reader while you are attempting to start the service HTH. Apr 12, 2013 at 15:22
  • No policy, I'm also the domain admin and I'd know it. No restrictions of any kind, and no proxy settings. I can login as the farm account and do anything I wish (it's a local Administrator on the server).
    – Massimo
    Apr 12, 2013 at 15:33

1 Answer 1


Ok, I know this sounds completely crazy, but here it is: in order for the UPSS to be provisioned and start working, I had to configure the farm service account to have English regional settings.

The server is an English edition of Windows Server 2012, with an English installation of SharePoint 2013 and its Italian language pack; and, since the server is actually in Italy, the default regional settings are set to Italian, and thus the regional settings for all new user profiles are set to Italian; this includes, of course, the farm service account.

This is enough for the UPSS to painfully crash with that totally unrelated "HostId is not registered" error.

I don't know if the actual requirement is "the farm service account should have regional settings matching the O.S. language", or "the farm service account should have regional settings matching the installed SharePoint edition", or even "the farm service account should have English regional settings and will not work with anything else".

What I know is, this is completely crazy, absolutely undocumented, and definitely the sort of behaviour an expensive software released in the year 2013 with f**cking built-in multi-language support really can't afford to exhibit.

  • Could you please provide the exact steps that you took to correct the issue? It's not clear to me what you mean configure the farm service account to have English regional settings. Nov 3, 2013 at 21:13
  • 1
    I had to actually log on to the server using the farm service account and change the regional settings for that user.
    – Massimo
    Nov 3, 2013 at 21:22
  • OK, that is officially the stupid. +1 for you figuring this out. Sadly this cannot be the issue I am having as there are no language packs (SP or otherwise) installed on the server. This is killing me. Nov 3, 2013 at 21:32
  • It sounds crazy but it works. Just had to change Region Formats & Location. A similar issue happens when installing the workflow manager 1.0 for running the 2013 workflow engine. Thanks Feb 26, 2016 at 9:57
  • 1
    @Massimo you just saved my day for the second time in a couple of years. Still wondering how this problem is even possible...
    – Evil Toad
    Jan 20, 2017 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.