currently I'm creating a custom workflow action for SharePoint Designer 2010. After the first deploy succeeded everything looked fine. But after that I changed several things and re-deployed the solution. That succeeded as well, but when use that custom workflow action now it is still the old one without the changes I made. How can I get it to use the new version?

Edit - Additional Information:

I created a "workflow action" (the things you add while building a workflow in SharePoint Designer like "set field to xyz" (so the part that doesn't work isn't the workflow itself). And I wrote it in Visual Studio while following those tutorials: http://msmvps.com/blogs/sundar_narasiman/archive/2010/12/26/develop-custom-workflow-activity-for-sharepoint-2010-workflow.aspx http://blog.symprogress.com/2011/01/spd-2010-custom-workflow-activity/

When I open SharePoint Designer to edit some workflow... the workflow action, that I created, appears in the dropdown just as it should and I can use it. But when I add the action to the workflow it still behaves like after I first deployed it. The changes aren't there.

I tried an IISReset, yes. I even rebooted the server.

Another edit: I noticed something new now. The workflow action DOES change but not fully... I can change the FieldBind (the text attribute for example) but when I change a parameter it doesn't work. I wanted to use another DesignerType but nothing happens if I change it and deploy again

This is my .actions file:

    <?xml version="1.0" encoding="utf-8" ?>
    <Action Name="Merge Users"
        Assembly="MergeUserActivity, Version=, Culture=neutral, PublicKeyToken=131c449c41275d01"
        Category="My Custom Activities"
      <RuleDesigner Sentence="Merge %1 and %2 (output to %3)">
        <FieldBind DesignerType="ListNames" Id="1" Text="users1" Field="UserSource1" />
        <FieldBind DesignerType="Stringbuilder" Id="2" Text="users2" Field="UserSource2" />
        <FieldBind DesignerType="ParameterNames" Id="3" Text="field" Field="UserTarget" />
        <Parameter Name="UserSource1" Type="System.String, mscorlib" Direction="In" DesignerType="ChooseListItem" Description="First user source." />
        <Parameter Name="UserSource2" Type="System.String, mscorlib" Direction="In" DesignerType="DataSourceDropDown" Description="Second user source" />
        <Parameter Name="UserTarget" Type="System.String, mscorlib" Direction="Out" DesignerType="WritableFieldNames" Description="Output field for merged users." />
        <Parameter Name="__Context" Type="Microsoft.SharePoint.WorkflowActions.WorkflowContext, Microsoft.SharePoint.WorkflowActions" Direction="In" DesignerType="Hide" />

When I deploy the action, it uses still "ListNames" and "StringBuilder" as DesignerType as from the tutorial that I used and it seems like I cannot change that...

  • Can you improve the question by adding specific changes to the workflow made. This will help us understand the problem better.
    – ArkoD
    Apr 4, 2013 at 11:34
  • Tried an IISReset?
    – James Love
    Apr 4, 2013 at 12:04
  • Try to delete workflow from list/site and then assign it again. However, this should happen only to already running WFs. Do you deploy through Visual Studio or PowerShell?
    – luccio
    Apr 4, 2013 at 12:08
  • I didn't create a workflow but a "workflow action" (the things you add while building a workflow in SharePoint Designer like "set field to xyz". (Sorry didn't know, that enter sends the post - still editing)
    – Jess
    Apr 4, 2013 at 13:52
  • Okay, I edited the top post for more information.
    – Jess
    Apr 4, 2013 at 14:01


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.