I am trying to access a Rackspace-hosted SharePoint 2013 Demo site via CMIS.

Unfortunately, I get this error:

enter image description here

I am sure the CMIS URL is correct, because I receive an app:service XML file when I connect with this URL/user/password via a web browser.
I tried all 3 Binding options, no luck.

I can access the SharePoint web UI normally.

Sounds dumb, but maybe a human user is required to log in manually via the web interface before the CMIS endpoint is accessible to this session? Demonstration:

(1) Try to log in via curl:

$ curl -u MyCorp.user1@raxsp.com:mypass https://mycorp.raxsp.com/personal/mycorp_user1/_vti_bin/cmis/rest?getRepositories

(2) Try to log in via Chrome:

  • Type URL https://mycorp.raxsp.com/personal/mycorp_user1/_vti_bin/cmis/rest?getRepositories
  • I am immediately redirected to an HTML page with a big red Sign In to SharePoint button.
  • When I click on the button, a browser dialog appears, saying The server https://mycorp.raxsp.com:443 requires a username and password
  • When I enter username/password and press Enter, the rest file is finally downloaded. I am happy, but the human step is a problem, CMIS is for scripts, not for humans.

(3) Trying the link behind the big red button with curl:

$ curl -u MyCorp.user1@raxsp.com:mypass https://mycorp.raxsp.com/_windows/default.aspx?ReturnUrl=/personal/mycorp_user1/_vti_bin/cmis/rest?getRepositories

Result: SharePoint error page saying: Access is denied. Error message 401.2.: Unauthorized: Logon failed due to server configuration. Verify that you have permission to view this directory or page based on the credentials you supplied and the authentication methods enabled on the Web server.

So, how to get rid of this human step, and let a tool/script access the CMIS endpoint?


Sounds dumb, but maybe a human user is required to log in manually via the web interface before the CMIS endpoint is accessible to this session?

I believe problem is with mode of authentication being used by CMIS or it got something to do with SSL (443).

I remember when I was trying to create a desktop gadget for windows 7 and was trying to get list items from SP 2007 list using HTML, JavaScript and web services but I couldn't as ISA server didn't let me pass through and ended up with same error as yours. I remember of trying hundred of ways but at end I gave up as it worked for HTTP but not for HTTPS.

  • The CMIS protocol supports both HTTP and HTTPS, yes. Actually, I have no problem connecting to Alfresco, FileNet, Nuxeo and other CMIS servers with a simple curl -u user:password https://url-to-cmis-endpoint... only SharePoint fails at this. Apr 2 '13 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.