When editing a Person or Group field in a datasheet view I always get the following error:

The user does not exist or is not unique.

If I enter the same name in the edit form it works fine.

Does anyone know of a fix for this? Any good workarounds?

  • this issue is repeated in SP ONLINE - O 365 version as well.
    – samolpp2
    Oct 5, 2018 at 14:15

2 Answers 2


I found this forum and this blog that discusses the same problem. It is because the Display Name for the user has a "," in it.

The response from Microsoft is:

this is a known issue that when using a Task/Project Task list in the gantt view, if you use People Picker control and choose a user name with a comma in the “assigned to” field, it will shows “The user does not exist or is not unique” as is displayed in the picture you provided. We have taken efforts on this. Hope this issue can be resolved in the next release of the product. For a workaround, you may consider modifying the user name without comma in it.

Obviously it was not resolved and now the datasheet view in SP 2013 is using the same control. Since removing commas from names just so SharePoint could figure out a name was not an option but I was able to use the users e-mail address as that is unique on our farm.

Some other workarounds that were suggested:

  • Use the user’s alias instead of DisplayName when entering it into the row. The Gantt chart will accept the value in this case, however this precludes use of the People Picker.

  • Where applicable, use the “New Item” option in the ribbon

  • 1
    "removing commas from names just so SharePoint could figure out a name was not an option" , just FYI, if you wish, you can change the user display name automatically as part of the AD-SharePoint user sync process as described here: pholpar.wordpress.com/2013/08/21/…
    – pholpar
    Feb 19, 2015 at 11:16

Just to let you know the answer to your issue is solved here:

Anything other than username in Person or Group column will not resolve only in quick edit mode

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.