1

I met an annoying problem when I try to upgrade my new version app 1.0.0.1 to my SharePoint 2013 server.

The detail steps I did,

  1. Create a development site in sp 2013.

  2. Create a sharepoint-host app project in visualstudio.

  3. Using "deploy" to deploy the app to sp2013.

  4. Now the version number is 1.0.0.0, and everything looks good.

  5. I made some changes and set a new version number at AppManifest.xml 1.0.0.1.

  6. using

    $spapp = Import-SPAppPackage -Path .\DevCore.AppCalendar.app -Site [http://sp-ss2013/sites/testapp] -Source ([microsoft.sharepoint.administration.spappsource]::ObjectModel) $instance = Get-SPAppInstance -AppInstanceId 4c472c85-2759-489f-8435-c6cc7b11eb91 -Site [http://sp-ss2013/sites/testapp] Update-SPAppInstance -Identity $instance -App $spapp to update the appinstance.

  7. after the update process has been done, check the app detail, it is the new version number.

  8. But all stuff in app look the same, the change doest work at all

I tried iisrest but it turns out the same result.

Really need help, otherwise I have to reinstall the app......

/Dong

1

i figure it out my own. besides changing the version number of app, we need to add ReplaceContent="TRUE"/ at element.xml and change a bit of feature.xml as we did at sharepoint 2010

  • Did you have any details on the changes you made to the feature.xml as we are experiencing the same issue without any resolution so far? – user37294 Jun 4 '15 at 16:01
0

What is your app displaying?

It could be that the browser is caching the apps javascript causing it to not fetch the latest version of your scripts. Try Ctrl + F5 to force the browser to retrieve the latest scripts

  • Hi Robert, the app displays some calendar and buttons. To do a trail, I only change the text of buttons between two version. I have already tried clear cache and reload. – Kelvindong Mar 28 '13 at 10:30
  • Maybee you should clarify your question with this information? – Robert Lindgren Mar 28 '13 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.