0

I have a strange behaviour in my SharePoint site. When I search for an item in a library, it is returning a link to the library (allitems.aspx), rather than a link to the individual item. Example, I search for Item A. It returns a link to the All Items View of the library.

Is this a configuration issue? Where should I direct my investigation?

Any assistance would be greatly appreciated.

I am using SharePoint 2010

0

If I am understanding your question correctly, when you search for document "A" the results are returning document "A" AND the document location such as "http:/site/document A/SharedDocuments/AllItems.aspx.

If this is the case, remove the AllItems from the results by:

  1. Opening Centeral Administration
  2. In the "Application Management" section, select "Manage Service Applications"
  3. Select the "Search Service Application"
  4. On the quick status bar to the left, select "Crawl Rules"
  5. Create a "New Crawl Rule"
  6. In the path field type - http://*allitems.aspx and select OK
  7. Select Content Source and start a full crawl

If your visual, check out this link:

http://weblogs.asp.net/coltk/archive/2011/07/19/crawl-rules-tips-in-sharepoint-2010.aspx

  • Thanks for your reply. No, unfortunately it is returning the all items only. however, I will check the crawler settings including the crawl rules and let you know,thanks again. – Joseph Caruana Mar 27 '13 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.