I have some problems with sahrepoint 2010 account management...

In my windows 7 i have 2 accounts: an administrator account (let's call it "admin") and a standard user (called "reader"). In the SP2010 central administration i have correctly added both accounts as "managed accounts". In my site i have modified the "site permissions": "admin" account was already in the "[Site collection name] Owners" group, and i have added the "reader" account to the "[Site collection name] Visitors" group.

When i open a SP website i have to login: let's say i log in as "reader". Then i want to log in as "admin", so i select "Sign in as a different user" in the top-right corner of the page. Now when i insert username and password of the "admin" account, i get some kind of error, as if the password is wrong (but i get no message, just the same window again asking me for username and password). At the third attempt, i get the 401 UNAUTHORIZED page. But when i close the page a re-open it, i result logged in as "admin", without having to insert username and password!

Is this a normal behavior? Otherwise, what could be the problem?

3 Answers 3



Regedit -> HKLM->SYSTEM->CurrentControlSet->Control-> LSA Create a DWORD Entry and set the Value data "1"

A loopback security check was introduced in Windows Server 2003 Service Pack 1 and it is also present in Windows Server 2008. The loopback security check feature prevents access to a web application using a fully qualified domain name [FQDN] if an attempt to access it takes place from a machine that hosts that application. A 401.1 Access Denied from the web server and a logon failure in the event log will occur. This means that browsing a SharePoint Web Application that uses a fully qualified domain name from a WFE in the farm will result in 401.1. This is very annoying on a development box, or when testing locally, or in other SharePoint specific scenarios. Microsoft calls this a security feature.

  • This works for me! After you get to LSA folder, create a DWORD Entry named DisableLoopBackCheck and set value to 1. Dec 29, 2012 at 20:11

1) check the version of IE 2) Close the session clear the cache . It should ask you credentials , then try to log in as reader .Hope that helps

  • My IE is version 8 (8.0.7600.16385 to be precise) To close the session i just have to close all explorer windows right? And to clear the cache i have to "Delete borwsing hystory" (by selecting all checkboxes)? If all i have done is correct, the problem is still there. Anyway, understanding that it is a browser problem, i use firefox now, which seems to work without this problems
    – Anonymous
    Oct 20, 2010 at 7:14
  • IE act weird . I usually have both IE and firefox.I am glad Firefox worked out for you .. good luck Oct 22, 2010 at 16:12

You may want to try changing the security policy for your site in IE settings and make sure that your site is under Local Intranet security zone, if you have not done so already.

Go to Control Panel Go to Internet Options Click the "Security" tab Click "Local Intranet" Click "Sites" Click "Advanced" Add your SharePoint site into the "Local Intranet" zone.

  • Yes i have already tried to set this, but nothing changed =(
    – Anonymous
    Oct 20, 2010 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.