We have an SharePoint 2007 publishing site which is accessible through a "www" public address for anonymous access and FBA access to certain areas. The site is also accessible through an extended "edit" url for internal users to edit the content. One particular area of the site is for FBA users (though administrators can also access it through the edit site). We have configured this area of the site to not "Show Pages" in the navigation (Site Settings > Navigation). However, the FBA site is ignoring this setting and is displaying all pages in the Quick Launch menu. The same site accessed through the "edit" url is honouring the setting and is not showing any pages. I cannot find any reasoning for why this is happening.

It also seems to be somewhat random in that some days it is behaving as expected, others not. It can also occur on specific servers within the farm. I.E. we have 2 web front-ends, one could be displaying the correct navigation while the other is not. We do have a UAT farm that contains the same site (albeit from an older db backup) and we are not seeing the issue there at all. Sometimes an IISReset resolves the problem, sometimes not. I've tried resetting the cache (object, disk-based) but that had no effect.

If it helps at all this area of the site is fairly deep down in the navigation. It is 6 levels deep.

Does anyone have any ideas what might be causing this? Or know of any tools that might help us diagnose?

Appreciate your help.


1 Answer 1


Have you check the settings of you quick launch in your master page ? It could probably overwrite your site settings.

  • Hi. We are seeing this issue on uncustomised SharePoint pages, i.e. default sitemapdatasource and menu. If I specify "Show Pages" and then hide the unwanted pages they get removed. The trouble is a lot of pages are going to be added over time and these should not appear in the navigation, so that is not a solution here. Commented Oct 20, 2010 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.