0

SharePoint 2010 Publishing Site Intranet:

I have a team site with document libraries. For team members, documents are not coming back in search results. Can someone point me in the right direction - I thought this would have worked out of the box?

UPDATE:

Search is running regularly as scheduled and actually crawling the sites. This is basically an out-of-the-box scenario, no crawl rules, etc.

1 Answer 1

2

There are a million possible issues on this but here are a few places to start:

  • Is Search running regularly and actually crawling sites? (Search Admin - Crawl log)
  • Is Search even crawling the site? Check the crawl log and verify that the documents themselves are being included
  • Are there any Crawl Rules defined that might be excluding the documents?
  • Does the search crawl account have the proper permissions? (Central Admin - Security - Web application user policy)
  • Have the default search scopes been modified in some way? (Site Collection Admin - Search Scopes)
  • Is the site blocked from search (Site Administration - Search visibility)
  • Is the Library itself blocked from the search (List Settings - Advanced)
  • Is the library configured to only allow people to see their own items? (List Settings - advanced)
  • Search results are security trimmed so are the documents secured in some way that would not allow your team to see them?
4
  • For point 6 & 7, how do I get to Site Admin/Search Visibility and List Settings? Via Site Actions or Central Admin? Commented Mar 26, 2013 at 15:45
  • Site Settings and List Settings, respectively. Commented Mar 26, 2013 at 15:48
  • Updating question. Commented Mar 26, 2013 at 15:55
  • Turns out that users did not publish docs as major versions! Commented Mar 26, 2013 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.