I created a new web application.

I try to restore a site collection from a backup. It finished succesfully but when I type the url This page can't be displayed occurs.

I think the problem is about web application but can't find the reason.

I tried to create a new web app with new IIS web site and new App Pool or same IIS web site and same App Pool. I tried it with host header and without header but nothing happened. The message still occurs.

  • can any one answer this question?
    – Anand
    Nov 9, 2017 at 17:48

2 Answers 2


did you try to see ULS logs and identify the problem? Try to use ULS viewer to see what heppens in live...

This error explenation is quite high level but here are some ways to find it out:

  1. Did you try to see in your host file if site URL is within?
  2. Did you check out if URL is in IIS bindings?
  3. Did you access the site from server's browser? Did loopback is disabled?
  4. What is a site collection template used for the site you have backed up? What is SP version? Try to see if backed up site do not use features not available in SharePoint 2013 (if you are restoring SP2010 site) like workflow feature, analytics feature etc.

Hope it helps,


  • There is always ystem.Web.HttpApplication.PipelineStepManager.ResumeSteps(Exception error) error. not anything else. 2,3 is ok. My site collection template is projects site but I also tried with the other templates just for test and they didn't work too. My SP is 2013.
    – e.ozmen
    Mar 26, 2013 at 8:09
  • Is your backed up solution is branded one with some customization code? Mar 26, 2013 at 8:14
  • Sorry but I didn't understand your question. What does it mean?
    – e.ozmen
    Mar 26, 2013 at 8:18
  • In your solution you try to restore do you have some custom code? Any web parts, lists etc. craeted not OOTB? Mar 26, 2013 at 8:19
  • 2
    I created a web application with url : servername:portnumber and it worked. I guess the url name has to be same with server name and the port name is the only thing that specify it.
    – e.ozmen
    Mar 27, 2013 at 9:36

Some times getting Users Access Permissions denied, so add site collection administrator using Central Admin --> Application Management --> under Site Collections --- Change site collection administrators

  • I did it when I created it and I checked it. No problem about it.
    – e.ozmen
    Mar 26, 2013 at 7:44
  • you check web application user policy, there you add user and give access full control. Mar 26, 2013 at 7:50
  • it didn't work.
    – e.ozmen
    Mar 26, 2013 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.