4

Does anybody know how to turn off automatic text conversion into mailto: links inside basic single line of text fields? It is confusing a little bit. Our customers stores server configurations in lists with various columns like number of processors, HDD type or CPU speed and if they insert something like this: [email protected], some processes in the background convert it into active mailto: link. I know, we can create items without both @. symbols, but I would rather disable it. Thanks

enter image description here

1
  • fwiw - I just verified that it is SharePoint that it doing this as the mailto: is in the original html that is being sent by SharePoint. It is not being done in the browser.
    – Dave Wise
    Mar 22, 2013 at 16:08

3 Answers 3

5

someone had a similar issue to you:

their solution was to use jquery:

$(function() {
    $("a[href^=mailto:]").each(function(){  
        var sEmailAddress = $(this).text();
        $(this).replaceWith(sEmailAddress);
    });
});

Preventing SharePoint from converting email addresses to mailto links

1
  • I'm afraid, that this solution will not be accepted here but thank you, its worth to try
    – Molik
    Mar 22, 2013 at 16:47
4

I am not seeing any way to turn this off but I discovered that if you create a new Calculated field and simply set that field equal to the field giving you trouble that it does not add the mailto link on views. It would at least be a workaround

1
  • This unfortunately doesnt work for multi-line fields as those cant be used in formulas :(
    – chukko
    Sep 21, 2017 at 14:00
3

Add spaces?

This stackexchange post might help. I think it's a browser thing and not Sharepoint doing that.

2
  • That's what I need, fully supported (here) is IE anyway. But, I think turning this automatic URL detection off means deactivate links everywhere (including site pages). Could be turned off for selected pages (lists) only? (I'm sorry, I'm not a programmer)
    – Molik
    Mar 22, 2013 at 16:56
  • There might be another issue caused by browser, but SP for sure does the replacement - it is biting me wheni try to use the plain text description in the title attribute.
    – chukko
    Sep 21, 2017 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.