3

Whenever the user clicks on a Word file in Sharepoint Document library, he first gets the normal dialog asking Open/Save/Cancel.

After opening the document once the document gets opened up , but then next time whenever we click on the attached /uploaded document it opens directly without showing Open/Save/Cancel Pop up.

Even if i check the option "Always ask before opening this kind of document" it does not show pop up again.

I need to have this Pop up always when we click on any doc or xlsx file fron the Document library items. Is there any setting needs to done or some javascript could be called to make this setting.

  • is this local to your pc only? what browser are you using? – Ali Jafer Mar 22 '13 at 10:47
1

How does SharePoint determine whether to send the "X-Download-Options: noopen" HTTP Response header (i.e. whether to present a Save or Open option to a user)? The following notes outline the various scenarios through which SharePoint makes the determination to send the “X-Download-Options: noopen” HTTP Response header. When serving a file, SharePoint 2010 and 2013 use the following logic (from a high level): •Check the Web Application’s Browser File Handling Property
◦If it is “Strict” then all untrusted files within the Web Application will always include the include the “X-Download-Options: noopen” header in the HTTP response. ◦If it is “Permissive” then SharePoint will check the Browser File Handling Property of the list or document library within which the file resides. This is an override of the Web Application Browser File Handling setting:

■If the List/Document Library Browser File Handling Property is set to “Strict” and the MIME type being requested is not on the trusted MIME type list (i.e. the Web Application's AllowedInlineDownloadedMimeTypes), then the HTTP Response will include the “X-Download-Options: noopen” header.

■If the Document Library Browser File Handling Property is set to “Permissive” then the HTTP Response will omit the “X-Download-Options” header.

Some important additional notes:

•You cannot override the Browser File Handling Property at the List/Document Library level to be more accommodating than at the Web Application level. For example, if your Web Application’s Browser File Handling property is set to “Strict” and then List/Document Library within the Web Application is set to “Permissive”, the HTTP Response will include the “X-Download-Options: noopen” header unless the MIME type being served is on the trusted file list.

•You can override the Browser File Handling Property at the List/Document Library level to be more restrictive. For example, if your Web Application is set to “Permissive” and then set a Document Library to “Strict”, the HTTP Response will include the “X-Download-Options: noopen” header unless the MIME type being served is on the trusted file list.

•For the “X-Download-Options: noopen” header to be omitted completely one of the two scenarios must be true: ◦The MIME type being served is on the Web Applications trusted file list, or ◦The MIME type being served is not on the Web Applications trusted file list and the Browser File Handling Property for both the Web Application and the List/Document Library within which the file resides is set to “Permissive”. •It is important to stress that the trusted file list is unique to a Web Application. The number of trusted file lists (i.e. AllowedInlineDownloadedMimeTypes lists) you have is equal to the number of Web Applications you have in IIS serving SharePoint sites. This is important to understand as if you wish to add “application/pdf” to all trusted file lists within your SharePoint environment, you’ll need to add it to the trusted file list for each Web Application that serves SharePoint sites.

http://social.technet.microsoft.com/wiki/contents/articles/8073.sharepoint-2010-and-2013-browser-file-handling-deep-dive.aspx#How_does_SharePoint_determine_whether_to_send_the_X-Download-Options_noopen

now you know you can set this accordingly:

•Browse to the Central Administration site, click Manage Web Applications under Application Management.

•Select the web application and click onGeneral Settings from the ribbon

•Scroll down to Browser File Handling, and choose Permissive instead of Strict.

http://support.microsoft.com/kb/2661910

changing it to permissive only works for the web root level and would require powershell script to go through sub sites or use this console app:

http://www.ride-the-bytes.com/?p=886

if your case i think it should be strict as you want the dialog box to appear!

0

Do you mean like; when clicking a word file it should pop up with a box asking "open read only or open edit"??? Maybe the settings below might help:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.