Last I night I was trying to deploy a custom timer job on production servers, I added solution easily using STSADM, but when I tried to deploy it using CA it returned with deployment status as Failed.

Tried to execute all timer jobs using stsadm -o execadmsvcjobs it executed the deployment job perfectly and timer job worked perfectly.

Now I needed to upgrade timer job so I tried to retract it (so I can re-add it) as I don't believe in upgrading it as most times it doesn't upgrade properly "Even if you recycle application pools or restart windows timer job", anyway while retract using STSADM it said operation completed when in CA it was saying status as failed again.

In short I tried to retract and deploy solution several times and also tried enumdeployments for cancellation jobs but at end I couldn't be able to deploy my solution properly

Can someone tell me what could be the problem with WFEs I got two of them.

Please note, its a Don't google it question.

Solution didn't had problem while deploying on Virtual PC, Dev, Int but only Production.


I do have proper permissions and someone else tried it too and had same problem. I tried it on both servers one by one as well but no gain.

1 Answer 1


I am able to deploy solutions to this farm without troubles I faced before.

First thing you must understand that if your farm is playing up synchronizing with other WFEs in same farm then don't use CA to deploy solution to web apps as most likely it will time out.

Second, deploy your solution on one of WFE using STSADM (for MOSS 2007) and then after about couple of minutes of wait run this command on all of WFEs,

stsadm -o execadmsvcjobs

Above trick worked for me and deploys solutions to all WFEs without any time outs on Live environment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.