I have a default.aspx page that is configured as the home page. Users access the site under forms authentication. When they come in to the site, they get an access denied message (site collection administrators see this as well). If they then navigate to default.aspx by changing the URL, the page displays properly.

In other words, it appears that the permissions to the home page are set properly, but users who access the portal are not being redirected to the home page following login. Instead, they are hitting some other resource to which they do not seem to have access (and for some reason, SCAs have no access either). There is no redirect url being specified in the querystring, so they should be taken to the home page.

I have tried recreating the home page or setting a different page as the home page and it still fails to send users there.

Has anyone seen an issue like this?

  • What mechanism did you use to set the homepage?
    – James Love
    Mar 19, 2013 at 19:48
  • @james I set it in SharePoint Designer by right-clicking the file, and I also tried setting it in PowerShell.
    – J T
    Mar 19, 2013 at 19:52

3 Answers 3


Disabling and Enabling the Anonymous access at the Web Application resolved issue for me

  • Worked like a charm Apr 20, 2015 at 21:44

I had to set the portalsuperuseraccount and portalsuperreaderaccount properties on the web application:

 $app.Properties["portalsuperuseraccount"] = $sUser
 $app.Properties["portalsuperreaderaccount"] = $sRead

For more information.


It sounds as if there is an asset (like a css file, image, or master page) that is not check in published and aproved as a major version.

  • What about Site Coll Admins also getting the 404? Also, if he navigates directly to the page it loads (apparently).
    – James Love
    Mar 19, 2013 at 19:49
  • I don't think this is the issue. If there were something like this, then default.aspx would not load at all.
    – J T
    Mar 19, 2013 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.