I was under the impression that if you have a column with a required value, the dialog "Edit Properties" should be displayed automatically when trying to upload a file.

I distinctly remember seeing this happen before, but now it doesn't happen. The column in question has the default value field empty in the settings.

Do I have to do something else to make this work?

  • Does the library have different content types enabled?
    – teylyn
    Commented Mar 18, 2013 at 23:26
  • The one where I first discovered this did, but I have since tried libraries both with and without enabled content type management... Same problem either way. Commented Mar 19, 2013 at 4:32
  • Is versioning enabled on the library? See this question
    – teylyn
    Commented Mar 19, 2013 at 4:40
  • Again, same thing, I tried both with and without versioning enabled... Commented Mar 19, 2013 at 22:29

2 Answers 2


I did some test and found the following having SharePoint Site Collection Feature SharePoint Server Publishing Infrastructure active and Site Feature SharePoint Server Publishing Deactivated.

When you drag-and-drop a document to the document library with a required field, it uploads just fine without gettig the Edit Propoerty Dialog. My guess is that you use the same method uploading up to 100 documents at the same time you don't want to edit proiperties at the time of upload. But the document is checked out to you and no one else can see it, until you check them in. And (you guessed it) you have to add the required field in order to make the check-in and possibly publish the document.

But if you upload a document using the Upload button you get the Edit Propoerty Dialog where you can add the required field. You also get this informative text:

The document was uploaded successfully and is checked out to you. Check that the fields below are correct and that all required fields are filled out. The file will not be accessible to other users until you check in.

If you click Cancel in this stage, the document have already been uploaded - but are in the same stage as in the drag-and-drop feature. Even if it looks strange at first, it makes sense having this logic. You don't want to get stuck with a 100 documents pending on your actions. It's better to take care of the required field at a later stage.

Upload document with required field

In a project I experienced this with a collection of quality documents where you could bulk upload 200 documents in just two actions and later on add the three required fields missing before they where published.

Hopefully this make sense to more than me :-)


A quicker result than completing the steps above is by enabling Site Collection and Site Features.

Just enable Content Types - use the default document content type (it should inherit the columns already provisioned) and ensure at least one field if completed.

reference: "How to Ensure that Users are Prompted for Document Metadata in Office 365 and SharePoint 2016"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.