1

I have setup a test user account and added them to a group with read permissions. Now I'm new to sharepoint, keep this in mind.

I am trying to view a page I created with the Admin account, and it wont let me. I get this error: The page you're looking for doesn't exist.

Now of course the page does exist, but why is it doing this, and how can I fix it?

SP2013, thanks.

2 Answers 2

2

Does the page require publishing? Have you published it? If you still have problems after publishing, check the page permissions. While logged on as admin click page permissions > check permissions, enter the test user id and hit Check Now. That will show you the permissions that user has on the page. (The steps are from SP 2010, not sure if the commands are in the same place in 2013).

2
  • This was it, i saw the publish tab at the top and had to publish the page. This is a team site, and I turned off versioning, should it always need to be published?
    – binga30
    Mar 8, 2013 at 2:59
  • Publishing and versioning are two different things and can be turned on and off individually in the library settings.
    – teylyn
    Mar 8, 2013 at 3:52
0

check the page is completely Saved/published/approved by Admin. This is similar to any SOURCE SAFE process. Where you check-out, edit & then check-in (before which other users cannot see your code.)

Only then normal users can see that page. (if it's new).

If it's old page, then normal users will see an old version of the page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.