I have a document library with a custom document template. The template is an .XLTX file that I created using Excel 2010. It is associated to the library via a custom content type.

The template worked without any problems for at least a couple of weeks. Then, about a week ago, SharePoint started issuing the following warning when trying to create a new document using the template:

"The document could not be created. The required application may not be installed properly, or the template for this document library cannot be opened. Please try the following:

  1. Check the General Settings for this document library for the name of the template, and install the application necessary for opening the template. If the application was set to install on first use, run the application and then try creating a new document again.

  2. If you have permission to modifyu this document library, go to General Settings for the library and configure a new template."

This issue happens for myself, and most of my colleagues. It happens on both SharePoint 2007, and 2010. We all have MS Office 2010 (32-bit) installed on our client machines. I have already tried changing the file extension application association for .XLS, .XLSX, .XLTX and .XLT to make extra sure that they are all pointing to Excel 2010. It didn't make any difference.

Oddly, it is not an issue on my work laptop, which also has MS Office 2010 (32-bit) installed. I can't see any differences between my laptop and desktop configurations, but maybe I'm missing something?

  • The title says the document template is opened in Notepad. You don't mention this in question body, you only say that The document could not be created message is shown. Can you explain this? Jun 10, 2011 at 13:37
  • Did you try to open an Excel file by double-clicking it on one of the desktops? Jun 10, 2011 at 13:39

1 Answer 1


This type of Office integration issue is almost always because something has gone wrong with the ActiveX SharePoint controls provided in the Office client.

Try choosing the Repair option on your installation of Office 2010, reboot, and check if the problem has gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.