25

I need to change the order in which some fields appear on the new list item form for one of my custom lists. Regardless of the ordering in the view I have selected, the fields always seem to appear in the order they were created on the new item form.

Note: I don't have infopath so can't do it in there. Also, I'm using Sharepoint Online.

10
  1. Open the site with SharePoint Designer and navigate to your list
  2. Open the "NewForm.aspx"
  3. Move your favorite columns to the top

Best Regards from Munich

  • 3
    Ahh.. that got me most of the way there - newform.aspx doesn't seem to contain any fields specifically but I created a new 'New List Item' form and that does contain the markup for the field layout. Cheers. – Ben Mar 7 '13 at 16:09
  • Check the answer below, it is far easier to use than having to deal with Sharepoint designer... – GETah May 12 '15 at 9:48
61

Found the answer elsewhere that doesn't require SharePoint Designer:

Just a quick post in answer to a question I got yesterday: How do you change the order of fields in edit or display forms?

  1. Go to the list
  2. Enter list settings (from the ribbon in 2010, from the drop downs in 2007)
  3. Click Advanced settings
  4. Ensure ‘allow management of content types’ is checked
  5. Go back to the list settings
  6. In the list of content types associated with the list, click the one you want to change the order of fields for (in lists that have been created ad hoc this is usually item or document).
  7. In the bottom of the screen a link appears called ‘Column order’
  • 5
    Imo this is the best solution here, editting a page in SharePoint designer should only be done if there's really no other choice. – Christoffel de Gruyter Aug 15 '14 at 19:13
  • This is good because it also reorders the columns in the list view, hupseb's answer is good because it allows you to customize the layout more fully. – Charles Clayton Aug 6 '15 at 18:22
  • 1
    Confirmed working for SharePoint 2013 on-premises as well. – x__x Apr 5 '18 at 7:06
  • This technique may not work with lookup columns which include additional fields. I have several have of these in a list. Most of them appeared in the content type column order page, but one didn't. I play around a bit and now two additional fields no longer appear. I can't see any reason why these are affected but the other lookup column additional fields continue to appear. – JohnC Aug 9 '18 at 1:34
6

From the List, click List tab on the ribbon Click List Settings

Under Content Types header, click "Item" (It's a clickable hyperlink even though it doesn't look like it!)

enter image description here

Scroll to the bottom and click "Column Order" Update Position from Top number and click Ok.

  • +1 It's a clickable hyperlink even though it doesn't look like it the actual reason why having to look this up was even needed. – Amit Naidu Mar 8 '18 at 18:11
  • This is a duplicate of @AndyLevesque answer – JohnC Aug 9 '18 at 1:39
  • 2
    @JohnC Not entirely; it focuses on just the meat, and provides more information about the action required, including a helpful screenshot. – TylerH Aug 9 '18 at 17:54
2

Go into your List Settings and click 'Column Ordering' within the Columns section. Your column orders aren't set within the different views, that's only how they appear in the view itself.

  • 1
    I've changed the column ordering in there too but it has no effect on the new item form ordering. – Ben Mar 7 '13 at 15:45
2

To change the order displayed in the "New Item" pop-up form, click List under List Tools - Next click on List Settings on the ribbon at the right - scroll down to the end of the columns and click on the "Column ordering" link. There is where you reorder the items that will be displayed when clicking the "New Item" icon. That takes care of the New Item pop-up. If you want to change the order displayed in your normal list on the SharePoint site, click on "Modify View" icon which is just below the List tab - scroll down and reorder the numbering to what you want to see on your screen - then scroll to bottom and click "OK".

0

In my experience, you can only do this through Designer. Good Luck.

0

This answer comes from Social.MSDN via TechNet (scroll down to answer by Michael_ICS). It can be changed in the UI, don't have to use Sharepoint Designer. It involves hacking the list URL to "formedt" to access a dialog box that allows you to change the order.

The post was specific to alerts but it works with list forms as well.

0

Question: It appears that my column ordering option has gone away in my main view under List Settings. It has vanished from the section under the alphabetical list of my columns and before the Views section. Is this because I used InfoPath to make the form fancy?

  • This can happen if you have Content Type management enabled (more than one content types available). If you select a specific content type, you should get the option to order columns there – hoffie4 Feb 16 '17 at 18:06

protected by Community Dec 13 '17 at 12:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.