I get the following error when trying to import an excel spreadsheet into a SharePoint list.

"The specified file is not a valid spreadsheet or contains no data to import"

I have added this site to “Trusted Sites” list in the IE 8 but this does nothing.

Setup: I am using Excel 2010, Windows 7, IE 8, SharePoint Server 2010 which are all loaded on a Windows 7 laptop.

I followed these directions for importing a spreadsheet as a list: http://www.dummies.com/how-to/content/import-a-spreadsheet-as-a-list-in-sharepoint-2010.html

  • Is the problem just on your computer and whether did you tried it in any other browser and if it works then ? Commented Mar 6, 2013 at 23:36
  • I installed SharePoint Server 2010 on my Windows 7 laptop and everything is being run locally browser IE 8 accessing sharepoint site all on my laptop.
    – Remy
    Commented Mar 7, 2013 at 3:17
  • Does this happen with all spreadsheets or just this one? Commented Mar 7, 2013 at 3:58
  • It is happening with all spreadsheets. I followed these directions: dummies.com/how-to/content/…
    – Remy
    Commented Mar 7, 2013 at 11:08

2 Answers 2


Well, I searched some more and found the solution (thanks to SunnyLowe)

The real problem here is Internet Explorer (IE).

  1. In IE, from the File menu or Tools Icon, select Internet Options|Security Tab

  2. In the "Select a zone to view... ", click Trusted Sites so it is highlighted. Then click Sites to add the site to your trusted sites list. Tab. (This was already automatically done for me).

  3. Set the Security level for this zone of the Trusted sites to Low.
  4. Then reload the webpage, and it should load fine.

I had only checked # 2 and didn't see mention of# 3 of above until I found SunnyLowe's post here: http://social.technet.microsoft.com/Forums/en/sharepointadmin/thread/27279fd1-d3c5-4986-9810-416b294aec49


I had the same error when required field "Title" was hidden in the list and I did not insert data from EXCEL to that column.

Try to check out if there are columns in the list which are not in the excel. Try to copy column one by one...

Should be one or more column missing.

Hope it helps,


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.