0

I created a custom list and a blog in my SharePoint 2007 site. I added the RSS web part to my front page and enter the RSS Feed URL for the blog. I have a feed limit of 3. I only receive the most recent entry. I went to my blog site in the same collection > Manage posts > Settings > List Settings > RSS Settings. My Item limit is 15 and Maximum days is set to 365.

I have a custom list where I've attempted the same thing only to get the same results. The SP Admin can see 3 entries, but he's the only one. I also added a feed to another collection's list. Once again, only the latest entry shows.

ideas are appreciated.

0

I managed to fix this by changing out the XSL in favor of much simpler code. Maybe someone can tell me if this is an acceptable practice or if this looks fine. Credit to where I found the article that got me moving in this direction. http://stackoverflow.hewgill.com/questions/241/893/1.html

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet  version="1.0"   
exclude-result-prefixes="x d ddwrt xsl msxsl" 
xmlns:x="http://www.w3.org/2001/XMLSchema" 
xmlns:d="http://schemas.microsoft.com/sharepoint/dsp"
xmlns:ddwrt="http://schemas.microsoft.com/WebParts/v2/DataView/runtime" 
xmlns:xsl="http://www.w3.org/1999/XSL/Transform" 
xmlns:msxsl="urn:schemas-microsoft-com:xslt">

<xsl:output method="html" version="1.0" encoding="iso-8859-1" indent="yes"/>
<xsl:template match="/">
<xsl:for-each select="rss/channel/item">
<div class="item link-item">
<a><xsl:attribute name="href"><xsl:value-of select="link"/></xsl:attribute>
                <xsl:value-of select="title" />
            </a>
        </div>            
</xsl:for-each>                    
</xsl:template>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.