Is there a way to assign this permission level? Currently the lowest permission level that allows adding is Contribute. Unfortunately this allows users with this level to add/edit/delete all posts in this list? How can I make it so users can add to the list, but only have the ability to edit or delete their own posts?

3 Answers 3


If this is a List and not a library then this functionality is built-in. Simply go to List Settings - Advanced - Item level Permissions and you can configure exactly this behavior

  • Thank you very much! Sometimes there's just so much to look at I miss things like this.
    – LoneWolfPR
    Mar 6, 2013 at 16:15
  • Ok. I spoke too soon. I've added Item level permissions with the option checked, "Create items and edit items that were created by the user". The problem is users can still delete posts from other users. If I leave that option as is, and change the group to Read permissions on the List Permissions page then, they can't do anything. Is there some magic combination of 'List Permission' and 'Item Level Permissions' that allow users to add posts, but only delete or edit their own?
    – LoneWolfPR
    Mar 6, 2013 at 20:22
  • Nevermind. It sill shows the delete option, but they can't actually do it. They get 'Access Denied.'
    – LoneWolfPR
    Mar 6, 2013 at 20:29
  • The combination you are referring to is Contribute access to the list, and the list setting mentioned above. Aug 14, 2015 at 18:00

I had this problem too. I found an answer that actually works:

  1. Create a permission level with Delete Items selected

    • Site Settings > Site Permissions > Permission Levels >
    • From here you can either click Add a Permission Level or click on an existing Permission Level (i.e., Contribute), scroll down to the bottom and click Copy Permission Level. Give it a name like "Contribute Delete"
  2. Open SharePoint Designer as Admin or make sure the user account that you are signed in with has the permission to delete items)

    • Click on the list that you want to use your new permission level for
    • List Workflow > Type your Workflow Name > SharePoint 2010 Workflow > OK
    • Click above Step 1 > Click Impersonation Step
  3. Click inside the Impersonation Step > Action (Ribbon) > Under List Actions click "Add List Item Permissions"

  4. Click "these permissions" > Add > Choose > User who created the Item > OK > Check your permission level that you created in Step 1 > OK > OK

  5. Click "this list" > make sure Current Item is selected > OK > Publish the workflow

  6. Make sure that "Start workflow automatically when an item is created" is checked in the Start Options


I'm not sure if this is helpful or not.

You can configured a custom Permission Level (not to be confused with Item Level Permissions).

Site Collection --> Site Settings --> Site permissions --> Permission Levels (on the Ribbon).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.