2
 <h2 class="demoHeaders">Tabs </h2>
    <div id='tabs'>

Anytime i save the code in SP Designer 2010 the div changes to:

  <div id='tabs{generate-id()}'>

The trick in SP Designer was to create a variable and then use it but it doesn't work in SP Designer 2010. Any ideas?

  • What code have you tried already that isn't working? – iOnline247 Jul 21 '11 at 3:59
2

You need create a parameter:

<xsl:param name="videolinkshow" />

So,

<div id="back{$videolinkshow}"></div>
  • Creating a parameter or giving id in braces (e.g. <div id="{divId}"></div>) did not work. Any other way to do it? – user4939 Sep 22 '11 at 7:51
0

I blogged this here: http://geekswithblogs.net/naijacoder/archive/2010/08/20/141405.aspx Hope that helps

  • please add some insights from your article rather than just shameless plug your blog, please! :-) – Anders Rask Sep 22 '11 at 12:04
  • Anders anything wrong with what i did? No Idea – naijacoder Oct 24 '11 at 0:47
  • As i said: post relevant info in your answer and then link to your blog, else your answer might get misunderstood as overt self-promotion. Also we want our answers to stay in the site, since external links tend to become stale quite fast. Read more in our FAQ – Anders Rask Oct 24 '11 at 7:01
  • You didnt fix it thou ;) – Anders Rask Oct 24 '11 at 15:44
  • I will fix it for sure – naijacoder Oct 26 '11 at 0:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.