I got a strange problem with Sharepoint 2010 User Profile Synchronization Service (UPS).

I have User Profile Service Application(UPA) and User Profile Service is started. Two FIM Service is stopped (cause UPS not started?). When I tried to start UPS, it stuck in starting.

So, I stop UPS with PowerShell, then deleted old UPA and created a new one. I click UPA link, then got "An unexpected error has occurred". ULS Log shows:

  • UserProfileApplication.DumpSynchronizationStatusToFile: Unexpected exception: System.NullReferenceException: Object reference not set to an instance of an object.
  • UserProfileServiceUserStatisticsWebPart:LoadControl failed, Exception: Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: This User Profile Application's connection is currently not available. The Application Pool or User Profile Service may not have been started. Please contact your administrator.

Is it necessary that UPS & FIM Service started for managing UPA ? Or just User Profile started then we can see UPA page ?

If I want to start UPS, should I start two FIM service by manually operated ?

  • My UPA question seems like this - stackoverflow.com/questions/4428552/… . I do iisrest and restart "User Profile Service (not User Profile Synchronization Service)" many times, but didn't work.
    – evenrain
    Mar 7, 2013 at 1:56
  • Another Question is, I re-create UPA many times and create new Application Pool each time. How to delete un-used Application Pool ?
    – evenrain
    Mar 7, 2013 at 2:11

5 Answers 5


Setting up the User Profile Service is no easy task. Your problems seem very "normal", but you have to follow a couple of steps before you get it working.

First delete all your old User Profile Applications and all associated data.

Then follow the steps of this awesome guide from Spencer Harbar:

You won't find better information than this article. Follow it to the letter and you will have a working UPS. And by the way: You shouldn't have to do anything with FIM, everything should be done for you automatically.


Setting up User Profile sync is quite a extensive process and needs you to check a lot of things even before you start. To this end, I'm going to point you to one of the best articles on the net which will describe what you need to do: http://www.harbar.net/articles/sp2010ups.aspx

  • I have read this article, but the question that I should solve first is managed UPA. I create a new UPA and can't do anything but get "An unexpected error has occurred".
    – evenrain
    Mar 7, 2013 at 1:23

No its not necessary for the UPS & FIM service to be started for managing UPA. You can manage User Profiles, Mysite settings etc. In otherwords, you can see the UPA page even if the UPS & FIM services are in a stopped state.

If you want to start UPS, you DONT and should not start the FIM service manually. It should automatically start with the UPS.

I would try to reboot the server first and see if you get the error message.

After you get the UPA up and running, check permissions.

AD permissions and local server permissions (while provisioning) are important. If you are not running in a Windows 2008 R2 forest / domain mode or higher, then your UPS account should be a member of the "Pre-windows 2000 Compatible Access" group in AD. (thats 9 of of 10 times the UPS gets stuck in 'starting').

I have blogged about UPS permissions. Hope this is of help. http://www.jeremytaylor.net/2012/10/06/checking-the-user-profile-sync-permissions-sharepoint/

  • I saw the two FIM service is "Disabled", is it normal ? And should I change "Log On As" to "Local System" before I start UPS?
    – evenrain
    Mar 7, 2013 at 1:28
  • I think a thing that I can't see UPA page after I created it. But after I started UPS (even though it stuck on starting), I can see the UPA page. Why ?
    – evenrain
    Mar 7, 2013 at 1:49
  • did you check harbar.net/articles/sp2010ups.aspx ? Mar 7, 2013 at 13:10
  • My blog post (link posted in my answer above) points to harbar.net's article as well as to a codeplex permissions checker PowerShell script that would help troubleshoot your issues with the stuck on starting. The UPA page should display even if the TWO FIM services are disabled. Forefront Identity Manager Service (FIMService) Forefront Identity Manager Synchronization Service (FIMSynchronizationService) Dont change anything manually on those services! It should be the "farm account" - set by SharePoint. Mar 7, 2013 at 13:19
  • Yes, I search my issue few days ago in Google. Many people provide harbar's article link. But I couldn't open UPA page now, so I think I should solve it first.
    – evenrain
    Mar 8, 2013 at 2:38

Please Check "SecurityTokenServiceApplicationPool" in Application Pool in IIS is Started or Stopped. It should be Started. I have the same issue and SecurityTokenServiceApplicationPool was stopped. So i started SecurityTokenServiceApplicationPool and did IISRESET and recycle the timer service.I stopped and started User Profile Sync Service and it worked with no issues.


Having had a very similar problem, along with many other associated problems, which put my work at an altogether unacceptable, extended standstill, I decided to post the resolution I found to as many forums relating to this issue that I could.

The resolution that I found was one of two things that I did at the same time (duh – not a smart tactic, but I was getting desperate…). I am not willing to spend the time to isolate the effects of each of these motions, so it could be one, or the other, or both.

  1. I noticed that SharePoint was moving the Farm Account Security Managed Account (The user account that Farm Account uses for credentials) from the Administrators group, to the WSS_ADMIN_WPG group. In my case Central Admin was being run on the same machine as the SharePoint Server. I run a single server developer environment. So the Farm Account needed “Log on Locally” privileges. WSS_ADMIN_WPG group did not appear to have the needed privilege, where the Administrators group did. Strangely enough though, the Administrators group is a member of the WSS_ADMIN_WPG group. So I moved the above mentioned user account back into the Administrators group.

Let me know if I’m not seeing something here….

  1. Upon examining the SecurityTokenServiceApplicationPool (the name I gave for the Security Token Service’s Application Pool), I notice that the Enable 32-bit Applications setting under the Advanced Settings had been set to True. This to me was strange as I remembered installing the 64 bit versions of everything, because the Server machine on which I was working was indeed 64 bit. So I set it to False. After those two simple motions I did all the familiar and necessary things to be done to make sure that the system and SharePoint was running with all the latest settings and tried what I had been doing once again, and to my amazement and shock (after having tried everything on the internet several times each) it worked! I am now happily moving forward in my work! At least until the next roadblock comes along.

Weird, dumb and stupid, what were the chances? Maybe it will be worth a quick look for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.