6

When I try to save as basic teamsite in SP2013 I get the following error:

[InvalidOperationException: Error copying temporary solution file to solutions gallery: _catalogs/solutions/test4.wsp]
   Microsoft.SharePoint.SPSolutionExporter.ExportWebToGallery(SPWeb web, String solutionFileName, String title, String description, ExportMode exportMode, Boolean includeContent, String workflowTemplateName, String destinationListUrl, Action`1 solutionPostProcessor, Boolean activateSolution) +4119
   Microsoft.SharePoint.ApplicationPages.SaveAsTemplatePage.BtnSaveAsTemplate_Click(Object sender, EventArgs e) +446
   System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) +146
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3586

However when I go to _catalogs/solutions/forms/allitems.aspx page I see that the soluton is saved. When I check the temp folder on the server it contains the wsp file. I checked the security on the temp folder and all entries have full control.

What do I miss?

  • 1
    Go to /_catalogs/solutions/forms/allitems.aspx and upload a wsp file. Can you do this? – Perplexed Feb 28 '13 at 15:50
  • Tried is and it worked – Remko Mar 1 '13 at 8:08
  • After saving the site as a template there a wsp in the solution gallery – Remko Mar 1 '13 at 8:11
3

The problem was my profile. It was kind of corrupt.

Somehow whenever I logged-in on my SharePoint 2013 server, windows could not find my profile and used a temperary profile.

Removing this profile and restarting the server solved the problem.

Removing temperary profiles describes the following various steps to solve the problems

How to fix it if you see those nasty “c:\users\TEMP” folders?

  1. Stop the relevant application pools
  2. Stop the IIS Admin Service (in services.msc)
  3. See that the TEMP folders are gone in c:\users

if the TEMP folders are not disappearing, or you are still getting a temporary profile, you can try to properly cleanup the temporary profile:

  1. Stop the application pools
  2. Stop the IIS Admin Service
  3. Using right-click properties on computer, choose advanced tab and then pick User Profiles. There you can properly delete them.
  • can you explain? same thing is happening. – Mike Dec 17 '13 at 18:57
  • 1
    Whenever I logged on Windows could not find my profile. Then a Temperary profile was loaded. The admins fixed this and removed the profile for me. After restarting the problem was gone. I read somewhere multiple restarts could solve the problem. – Remko Dec 18 '13 at 6:31
  • Added some extra information – Remko Dec 18 '13 at 6:57
1

My fix was because the solution gallery had versioning turned on. I turned it off, logged off, and tried it again.

0

If it is possible in 2013 - try increasing the site template file size as this can be a possible cause for this error: http://www.cjvandyk.com/blog/Lists/Posts/Post.aspx?ID=284

  • That I tried, but unfortunately it hasn't worked – Remko Mar 1 '13 at 8:07
0

Try to manually activate the feature and check the error.

I had the same issue, the solution was not activating, this solved the issue: https://erroreimprevisto.wordpress.com/2016/08/01/error-saving-template-sharepoint-2016-attribute-is-not-allowed/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.