2

I can create a site template without any problems and it will happily sit in the solution gallery all activated and nice looking. When I then try to create a new site and pick that template I get this error. The content type name '$Resources:DataSourceContentTypeName;' cannot contain: \ / : ? etc....

alt text http://arts.twynhamschool.com/templateerror.png

Just to be clear I've not used any of those illegal characters anywhere. Anyone seen this before or shed any light? All ideas welcome as I've tried many things already.

Chris.

2
  • Have you looked that correlation id up in the ULS log? This might give you more info on what is happening. Oct 7, 2010 at 15:47
  • Also plz supply the language pack you are running with, since ressource files are invoved Oct 7, 2010 at 17:31

1 Answer 1

2

Is this an upgraded farm? if so sometimes the content types fail on upgrade (specially for reporting services). If you go to content site content types you can see that the some of the content types are not getting their names from the resource file (eg: $Resources:Data......)

The way we solved this was by forcing to uninstall the reporting feature using http://featureadmin.codeplex.com/ (you can also use stsadm -force for this) and then actviate the reporting feature again from site collection feature.

Hope this helps

UPDATE: After doing this you will need to create the template again

2
  • It looks as if you've cracked it. I will try your solution and let you know.
    – user790
    Oct 8, 2010 at 12:54
  • Yes we had the same problem the other day (hence the update:))
    – Renzo
    Oct 9, 2010 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.