2

I had a major OS issue on a SharePoint 2013 machine, and unrelated external issues led to not having a backup. The machine ended up needing an OS reinstall, which I did as an in-place reinstall (upgrade existing Server 2012 to Server 2012). This fixed the OS, and in general SharePoint survived.

However, the SharePoint certificate store was lost. The SharePoint CA root is there, e. g. (Get-SPCertificateAuthority).rootcertificate gives a valid certificate. However without the store and its certificates, the STS is very unhappy.

This is a single-server farm. I have tried a reconfiguration and a repair followed by a reconfiguration, but neither solved this particular issue.

I am very close to starting over and pulling in the content databases but I wanted to know if there's an easy way to just get the store recreated. I don't know where the store and certificates originally come from (what part of what process puts them there) so I can't just do that one thing.

This is a single-server farm so grabbing from another server is not an option.

1

So ultimately I completely uninstalled SharePoint (which actually put the store back, but it didn't have any certificates), then installed it again, and went from there. I'm sure there's a better way but I ran out of time to figure it out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.