Yesterday I bought a web part from VirtoSoftware (http://www.virtosoftware.com/sharepoint-calendar). This uses javascript to show list items in any SharePoint list as calendar items in a web part. I

I tested this web part on DEV environment prior to deployment, with a variety of list and content types with no problems. Everything showed up like it should.

I deployed it to production and after a succesfull registration process I was ready to use it. I created the lists, added one of the content types I had tested prior to installation, created a test item in each list, and connected the lists to the web part. And the test items won't show up.

I can however create new items in those lists by doubleclicking and add new item via the same web part, so the connections to the lists are working. It just won't show items that are in the lists (not the old ones and not the new ones I create via the web part).

I used Fiddler2 to sniff out the http traffic and got this as a result:


The steps I have tried:

  • different browsers
  • googling 200 vs 304 http codes
  • several IISresets
  • quit and open browsers
  • edit the page (add/delete - from several client machines)

I'm hoping to find out how can I fix this, and hopefully get an answer that doesn't require reboot.

Thank you for your time.


1 Answer 1


Production servers probably have SharePoint Web Services blocked, you need to allow them in order to make components that use JavaScript to work.

They may have been blocked in web.config (see here) or with site collection lock down feature (see here). One could also block those earlier in IIS with, e.g., UrlScan (see here), or even perhaps on some smart-enough firewall, but I suspect the first options.

  • Thanks for the reply! (and Enter seems to mean apply) I have tried a reboot with no help, and have, thanks to your help, gone through the following: Added locations with allow all users in web.config files in both \Web Server Extensions\14\CONFIG and \Web Server Extensions\wpresources Ran get-spfeature, and it didn't show up in the site collection, and Powershell threw an exception when I tried to disable it. No firewall activated (got the problem even when I access locally on server) and no URLScan is used. Feb 27, 2013 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.