1

I'm having a problem correctly linking the My Site preferred search center to our main portal application's search center.

In the User Profile service, Setup My Sites link, there is a place to specify the preferred search center. No matter what you put into this field, it will automatically change to whatever the public URL is of the default zone for the web application of the search center you are trying to link it to. However, for our purposes, we need to use the search center with the Internet zone public URL, not the default zone public URL.

Here is my current AAM setup for the main portal web application:

Zone    | Internal URL | Public URL | Comments

Default | sptestapp01.adtest.company.com:443 | sptestapp01.adtest.company.com:443

Internet | insideisatest.company.com:443 | insideisatest.company.com:443

Internet | sptestweb01.adtest.company.com:443 | insideisatest.company.com:443 | This is web front end #1

Internet | sptestweb02.adtest.company.com:443 | insideisatest.company.com:443 | This is web front end #2

Here is the current AAM setup for the My Sites web application:

Zone    | Internal URL | Public URL | Comments

Default | mytest.company.com:443 | mytest.company.com:443

Default | mytest.company.com:447 | mytest.company.com:443

Default | sptestweb01.adtest.company.com:447 | mytest.company.com:443 | This 
is web front end #1

Default | sptestweb02.adtest.company.com:447 | mytest.company.com:443 | This is web front end #2

We reverse proxy everything through an ISA/TMG server, so the public access URL to the main portal is insideisatest.company.com and the public access URL to My Sites is mytest.company.com.

So right now, the preferred search center for My Sites is forced to be sptestapp01.adtest.company.com/searchcenter/pages, but we need it to be insideisatest.company.com/searchcenter/pages.

Does anyone know how we can do this? We can’t change the default public zone (sptestapp01.adtest.company.com), but cause that is needed for proper search results as well as keeping contextual search working.

migrated from stackoverflow.com Feb 26 '13 at 17:57

This question came from our site for professional and enthusiast programmers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.