I Made a console application that changes items in a list that has a Taxonomy field. The app works well on the Developement machine, but for some reason, when move it to production, we get this error:

"Unable to Install or run the application. the application requiers that assembly Microsoft.IdentityManagement.ExternalSettingsManager Version 4.0.2450.47 be installed in the global assembly cache first

I did some testing and it seems this error doesnt occur if the Microsoft.Sharepoint.Taxonomy isn't referenced in the project. Also, if i set the requested assembly as "Included" in the project properties, It just asks for a different Assembly.

*This might be important: the developement machine i worked on has updated for sharepoint installed that are not installed yet on the production env.

1 Answer 1


Your last point is very important as it sounds like your solution is binding to a newer version of the DLL than is available in Production. Your Development environment should always be the same version and patch level as your production environment or even a little bit older, if absolutely necessary.

One thing that might work is to edit your solution, right-click on the DLL reference in question and make sure that the 'Specific Version' property is set to false. This sometimes can make the difference.

  • Hi, Thank you for your reply. Unfortunately I already tried that, but to no effect.
    – sump
    Commented Feb 26, 2013 at 16:29
  • The only other thing I can suggest would be to copy the DLLs from production to a local folder on your dev machine (not the GAC) and bind to those instead of the ones in the GAC.
    – Dave Wise
    Commented Feb 26, 2013 at 16:34
  • Apparently that doesn't work as well. We eventually solved this by just compiling the code from another machine that had the same assembly files. But I can't help but wonder what the problem was..
    – sump
    Commented Feb 27, 2013 at 18:15
  • There must be something else going on then because I use this approach regularly to build SP2010 targeted console apps on my SP2007 farm.
    – Dave Wise
    Commented Feb 27, 2013 at 18:19
  • The problem seems to originate from the Microsoft.Sharepoint.Taxonomy assembly only (as far as i can tell). other sharepoint dlls work fine I'm still looking for what is causing this, I'll post updates if I find anything for future reference.
    – sump
    Commented Mar 7, 2013 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.