SharePoint Server 2010 (not just Foundation) If I go to Central Admin>Application Management>Manage service applications and select Business Data Connectivity Service, then click Administrators, I can type in a user, have it find the Active Directory user account or group and select to Add the user, and give permissions (Full control).

However, if I go into Manage for Business Data Connectivity Service I cannot do the same process for the same users/groups in the Object Permissions or the Metadata Store Permissions. How do I troubleshoot this?

I have tried different browsers, logging into the server with RDP to run Central Admin, checked that permissions on the sites and sub-sites work fine with Active Directory users (although some do not have their detailed information pulled over, in case that is related).

  • 1
    Any custom identity providers or claims providers in play? – James Love Feb 25 '13 at 22:43
  • All Users (PCSelfServiceMembershipProvider) and All Users (PC Self-Service STS) are listed when I try to browse for users. I am able to search and find Active Directory users and groups from that pop-up window. Those providers were installed with our Ellucian PowerCAMPUS Self-Service and Portal installation (vendor software). – Allan P Feb 25 '13 at 23:15
  • Did you found any solution for it ? – Rashid Apr 15 '14 at 11:50
  • As I stated below, it was our custom Claims Provider. We uninstalled and reinstalled it. If you were curious, it was PowerCampus Portal by Ellucian that needed the custom Claims Provider. Best of luck! – Allan P Apr 22 '14 at 20:26

James Love was on the right track. We uninstalled and re-installed the custom claims provider and the problem was resolved. Worked with Microsoft support for weeks before doing that, because they didn't think that was it. If you have a problem like this, try removing the claims provider in Central Administration>Solution Management (Central Admin, System Settings, Manage Farm Solutions).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.