I have set up a Sharepoint server 2007 in a single-server-farm configuration, which has to serve a single site database, that was restored from 2YO backup. The server's domain is different, although I have managed to configure a SSP to import accounts from the required domain. Now, I see that while the sync jobs run successfully, the user profile list in the restores Sharepoint site is not populated with new users (same domain, but more than 1Y timelapse). Investigation has narrowed to UserSites table in the SSP database that wasn't getting populated. The UserProfile_Full table correctly receives all the profiles, so the actual AD import is OK.

I have tried the following: preparetomove then undo, preparetomove-oldcontentdb, deletecontentdb, addcontentdb, preparetomove -undo. The latter worked partially, as the table got populated with SIDs of users that exist in the user list of the content DB, with correct "local IDs" (WssId column), but I want it to have FULL set of users to import into that content DB. I have also tried creating a new web application (after setting up the SSP), with new database, just in case the sync will actually work - no dice. I have also tried re-creating SSP, in case I made it wrongly - the other SSP gets populated with users as well, but the UserSites table is devoid of entries. I have then tried to move the main web application to be served by the other (newly created) SSP, just to see that neither table now has the population. Waiting is not an option, I have tried this as well. STSADM -sync -synctiming is set and working, as I see the tables get updated with current time, but no data actually gets transferred - I expect the jobs use UserSites table to retrieve data to import, and there is nothing.

So, the question is, how to repopulate the UserSites table via Sharepoint, as starting full import does nothing to accomplish this, OR perform a manual import using SQL stored procedures and other stuff, which I am yet unfamiliar with.

1 Answer 1


Instead of filling UserSites, I have just called WSS_Content.dbo.proc_SecAddUser on each user retrieved from UserProfile_Full, ignoring insertion errors (email==NULL, or preferredName==NULL, so what?). I'm not sure if it'll last, so I stuffed them into UserSites table as well. Maybe still I've missed something, though it should be easier to fix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.