I've been trying like a banshee to get Access Services working. I generally know my way around sharepoint.. I just can't for the life of me get this thing working.

I've literally installed SharePoint 2013 in a new environment five times- trying to try different combinations, and I just assume that I'm doing something wrong. I've tried VMs, every time I do this- I put SharePoint on a domain controller.. and the primary logins are all domain admins / enterprise admins.

I see that there's a new whitepaper from Microsoft about this, it was published on 2/7. I definitely have new and interesting information in this article http://www.microsoft.com/en-us/download/details.aspx?id=30445

I really believe that I've tried my best, and this just isn't working!

Here's a previous question from stackoverflow: SharePoint 2013 Access Services Config

I have been using the ULS utility to search for errors.. but now, I just don't get any decent errors, I can't figure it out.

Here is a dump of all of my logs associated with the latest correlationID, can someone look over these and help me to figure out what I should research?


  • Note: I was originally working off of this document (which, being from August is probably based on a beta) blogs.msdn.com/b/kaevans/archive/2012/08/30/… But I'm definitely NOT doing this part yet: 'Configure Isolated App Domain'.. sorry, let me do that part and then re-test. I just don't think that made it into this build :( Feb 15, 2013 at 22:34
  • I've done this 'Configure Isolated App Domain' powershell script, and I'm looking through those errors now. Feb 15, 2013 at 22:53

6 Answers 6


After sifting through your log dump, here's what stands out at me.

The first errors you encounter start at:

02/15/2013 12:29:26.60 w3wp.exe (0×1024) 0x208C SharePoint Foundation General adyrv High Cannot find site lookup info for request Uri http://win-fdshjv8jiql:32843/86ed9d455deb4308b14ed8f76394e215/AccessService.svc. 8f1bff9b-382b-8022-6d66-ab9bf55589bd

02/15/2013 12:29:26.60 w3wp.exe (0×1024) 0x208C Access Services Host Layer adiqc Medium The current application is null. 8f1bff9b-382b-8022-6d66-ab9bf55589bd

And sort of snowball from there.

A little further down you'll find:

02/15/2013 12:29:26.61 w3wp.exe (0×1024) 0x208C SharePoint Foundation Authentication Authorization agb9s Medium Non-OAuth request. IsAuthenticated=False, UserIdentityName=, ClaimsCount=0 8f1bff9b-382b-8022-6d66-ab9bf55589bd

I've noticed the claims user you're logged in as is not the same as the Windows Identity you're logged in as but there is no identity in the HttpContext:

02/15/2013 12:29:26.63 w3wp.exe (0×1024) 0x208C SharePoint Foundation App Deployment acjjg Medium The current user has System.Threading.Thread.CurrentPrincipal.Identity.Name = 0#.w|mcdba\administrator, System.Security.Principal.WindowsIdentity.GetCurrent().Name = MCDBA\mossfarmadmin, System.Web.HttpContext.Current.User.Identity.Name = . 8f1bff9b-382b-8022-6d66-ab9bf55589bd

Of course the actual error thrown during provisioning is so descriptive...:

02/15/2013 12:29:27.89 w3wp.exe (0x265C) 0x27F8 SharePoint Server Logging Correlation Data xmnv Medium Result=Microsoft.Office.Access.Services.Proxy.AccessServerSessionException: An error has occurred. at Microsoft.Office.Access.Services.Proxy.ServerSession.ExecuteWebMethodCore(WebMethodType webMethodType, WebMethodBehaviorAttribute webMethodBehavior, CommandParameter parameter, CoreWebMethod coreWebMethod) at Microsoft.Office.Access.Services.Proxy.ServerSession.ExecuteWebMethod(WebMethodType webMethodType, WebMethodBehaviorAttribute webMethodBehavior, CommandParameter parameter, CoreWebMethod coreWebMethod) 8f1bff9b-382b-8022-6d66-ab9bf55589bd

Unfortunately I don't have an answer for you, but I would try to log in to the box as the farm admin to perform this action instead of using different accounts. No guarantees, but I hope this helps point you in the right direction.

  • thanks, I'll definitely research. I was going to setup ODBC logging in IIS in order to start looking into some of those web service errors, that was my next step.. Will keep you in the loop on my progress, thanks! Feb 15, 2013 at 22:08
  • re: I've noticed the claims user you're logged in as is not the same as the Windows Identity you're logged in as but there is no identity in the HttpContext: Uh.. I'm going through this tutorial 'configure the secure store service in sharepoint 2013', and I setup a secure store app.. and then something about 'set credentials for a target application'.. and I'm doing something where I'm mapping two fields 'Windows Username' and 'Windows Password'- I guess I don't understand enough about what I'm REALLY supposed to do there. Feb 15, 2013 at 22:32
  • logging on as farm admin told me that I can't use the system account... Feb 16, 2013 at 3:37
  1. Is the Access service started on at least one server in Manage Services on Server
  2. Have you tried the installation on a physical box (non-VM)? Believe it or not, this can have an impact and it will help us narrow it down to a VM setting.
  3. What permissions does the App Pool Identity have (database, local)?

One common issue that you might check is whether the SharePoint Web Services application pool is running.

Open IIS Manager and look at the Application Pools. Make sure that application pool isn't stopped.

  • spot on.. that service 'sharepoint web services root' was definitely stopped. I started it. I'm gonna reboot everything and try again. THANKS.. Will keep you updated on my progress Feb 15, 2013 at 22:07
  • started the services. tried, and still got the same error from the Access side. I rebooted, tried again, got the same error again.. and now I pull up the application pools and this 'sharepoint web services root' service wasn't running, drove me crazy.. If I start a service, isn't it supposed to remember that setting the next time that the PC/IIS restarts? Feb 15, 2013 at 22:56
  • That particular service is a bit finicky, I would start it and try using the services (not rebooting after starting it). Feb 16, 2013 at 2:05
  • yes, I've definitely started that web service, tried creating Access services 2013.. and got nothing but 'an unexpected error has occurred' Feb 17, 2013 at 14:35

I'm not sure if this will help but I was successful following this post... Configuring Access Services 2013 on Premises

  • yes, that's the article I've been working from.. but I think that I was working on an older version of that article, it looks updated. One of these days when I got a spare week, I'll try to look back into it, thanks for the info! Any pointers to share!?!?! Mar 14, 2013 at 0:13

may be its too late with a new answer, but I only want to share my experience with this error.

I found this question googling exact problem and finally figured out how to solve it. In my situation I've gave securityadmin and dbcreator permissions for my sp_services account, then I decided to create new separate application pool for access services with sp_access account, and forgot to give above permissions for it.

So, to solve error in my case I had to add securityadmin and dbcreator permissions on SQL Server for sp_access (application pool account for access services).

Actual stack trace:

Exception while executing task 583a934b-9538-4107-aa16-f81351fdfe64 of type 
Microsoft.SharePoint.Packaging.SPDatabaseDeploymentGroup in job 
a4ed61c2-c9d6-4ef6-a51b-8d9b26ceb96e for instance c877f325-b0ac-464b-9cc7-5f91474c1291
 sitesubscription 00000000-0000-0000-0000-000000000000, rollback = False: 
 CREATE DATABASE permission denied in database 'master'.  

Just to add a bit more to @Kai's answer:

New-SPServiceApplicationPool -Name "AccessServiceAppPool" -Account contoso\sp_accessservice

$serviceapp = Get-SPServiceApplication *GUID-of-your-service-app*

$serviceAppPool = Get-SPServiceApplicationPool | ? { $_.Name -eq "AccessServiceAppPool" }

$serviceapp.ApplicationPool = $serviceAppPool

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.