2

On a Sharepoint 2010 Server, i tried running a script that needs to use Get-FASTSearchMetadataCategory.

Add-PSSnapin "Microsoft.FASTSearch.Powershell" returns an error, that the snap-in is unknown. Copying the dll to the directory did not help, registering in the GAC using gacutil did not help either.

How can I enable powershell to find the FASTSearch.powershell.dll? Does it have to be installed during the FASTSearch Server installation? I did not set up the system, so someone may have opted to not install this. I also never installed FAST, so I have no experience with the setup process.

1

The FAST commandlets are only available on a server which has FS4SP installed. And they are installed during the installation of FS4SP. There's even a management shell which preloads the snap-in.

  • Your answer is correct. When I finally got hold of the infrastructure guys behind the server i tried to run the script on, they explained that FAST isn't even installed there. Someone had told me otherwise, and I only had restricted access. – Niels Ziegler Mar 4 '13 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.