I'm trying to use Managed Metadata Navigation for cruising around my site. Right now I have a couple of team sites.

In the target settings I set the navigation URL to:


So far so good. But due to the MDS, the link I'm actually redirected to is (mind the null):


which of course should be:


Back to the term store: I tried setting the target URL to /department/production/ which is not a valid URL according to term store. I also tried the URL including the hash # but that URL also is not valid. So I'm stuck with using the above mentioned URL.

Anybody has any clue how I can set the URLs correctly without being redirected to null? (Sometimes it does work, when I visited the site once before it is redirecting to the correct URL).

2 Answers 2


I believe is because Managed Metadata Navigation is actually only meant for Publishing sites (definition is in Microsoft.SharePoint.Publishing.Navigation namespace), e.g. Topic pages, Friendly-pages - not particularly tested yet, but i've only used it as such.

MSDN also states "Managed navigation APIs are built into the taxonomy and publishing libraries in SharePoint 2013. " (http://msdn.microsoft.com/en-us/library/jj163978.aspx#SP15_ManagedNav_HowManagedNavWorks)

  • That could very well be. Interesting. I though it could be leveraged to be the one-size-fits-all navigation... Back to custom SiteMap providers?
    – Dennis G
    Commented Feb 10, 2013 at 23:07
  • It depends, it is meant to be created somewhere, and used elsewhere, sort of a "global navigation", centrally administered Commented Feb 10, 2013 at 23:10
  • Well I did create it on a publishing site. There are some team sites in the navigation though...
    – Dennis G
    Commented Feb 10, 2013 at 23:23
  • That is not the issue, but the issue is that your links need to point to Pages/mypages.aspx (Publishing). By the way, did you tried deactivating the MDS feature in your Site Settings Commented Feb 11, 2013 at 7:53
  • Sure I could deactivate MDS and I would have normal links - but that defeats the purpose of MDS ;-) I thought there is some way I'm missing.
    – Dennis G
    Commented Feb 11, 2013 at 15:57

You have to deactivate the Feature Minimal Download Strategy. When the Feature is active Links work correct if oppening another tab. Without the Feature Links always work correct

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.