2

Forefront identity manager service status is showing as blank in services console but I'm able to successfully start User profile service and User Profile Synchronization Service. But I couldn't synchronize SharePoint with AD because of this issue. This is the first time i'm facing such a weird issue.

I tried the following...

1 Restarted FIMS Server

2) Restarted SharePoint Server

3) Restarted UPS and UP Sync Service

I checked the event viewer and noticed the following error related to Forefront Identity Manager Service.

The Forefront Identity Manager Service cannot connect to the SQL Database Server.

The SQL Server could not be contacted. The connection failure may be due to a network failure, firewall configuration error, or other connection issue. Additionally, the SQL Server connection information could be configured incorrectly.

Verify that the SQL Server is reachable from the Forefront Identity Manager Service computer. Ensure that SQL Server is running, that the network connection is active, and that the firewall is configured properly. Last, verify the connection information has been configured properly. This configuration is stored in the Windows Registry.

enter image description here

2

Never ever fiddle with the FIM services manually - it will only cause more trouble for you.

Read through this article, after that you should not fail to provision the UPA sync.

/WW

  • I didn't start it manually. I very well know that user profile and UPSS will start FIMS automatically. – Kannan Feb 7 '13 at 22:45
0

Open central administration à security à Configure Service Account (On the drop down pick Farm Account) and ensure that the select and account for the component is the same as the one you are using to configure FIM (User profiles) the OK.

That should fix that issue.

Reference: http://geekswithblogs.net/leonardm/archive/2012/05/14/the-forefront-identity-manager-service-cannot-connect-to-the-sql.aspx

0

Do you have "Replicate Directory Changes" permissions set on your UPS Sync Account?

These permissions are mandatory for the User Profile Sync Service's Service Account.

Service Applications

Also, ensure that you have the following permissions set on the User Profile Service Application's "Administrators":

  1. Search Crawl Account = "Retrieve people data for search crawlers"
  2. Farm account = Full control
  3. Services account = Full control
  4. User Profile Service Account = Full control

Furthermore, you need to set the following "Permissions" for the User Profile Service Application:

  1. Farm account = Full control
  2. Web Application App Pool account = Full Control
  3. Services account = Full control
  4. User Profile Service Account = Full control

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.