I've set up two virtual machines on the same computer; one is Server 2003 running MOSS and the other is Server 2008 running Sharepoint Foundation.

I am able to browse the 2003 MOSS site from any computer on our network but for some reason I am not able to access the Sharepoint Foundation websites from external computers. Any suggestions as to what is causing this?

Both computers are on the same domain and where set up about the same time. Does not seem to be a DNS issue either as the Virtual Server's IP address also returns the unreachable error message, I tried setting a static IP address to.

I'm not sure what else I can try! I find it particularly strange that it's working fine on the 2003 version but not the other site.

C:\Users\alexh>tracert sharep2003

Tracing route to sharep2003.XXXX.COM [] over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms SHAREP2003 []

Trace complete.

C:\Users\alexh>tracert sharep2008 Unable to resolve target system name sharep2008.


Tracing route to over a maximum of 30 hops

1 Develop140610A.XXXX.COM [] reports: Destination host unr eachable.

Trace complete.

Flushed the DNS on local computer as well as our DNS server.

  • What is the subnet mask that is being applied to the sharep2008 machine? Maybe run ipconfig from command prompt and post the results. It might be that your host machine is unable to route the request to the sharep2008 machine as they are in different subnets. Also how is the sharep2008 machine bound to the host adapter. Has it been configured so that its bound to an adapter that is configured to not allow outside comms? – Simon Doy Feb 4 '13 at 19:32
  • There is no subnet applied and they're both on the same domain as the workstation I am trying to access them from. – Amicable Feb 4 '13 at 22:34
  • Sorry there is no subnet mask applied? There must be! Do you mean its just a default subnet mask of – Simon Doy Feb 5 '13 at 6:55
  • The network has not been subnetted as it has the only default mask, this is the correct terminology as far as I am aware! – Amicable Feb 5 '13 at 9:08
  • Sorry to correct you but having a default subnet mask is subnetting. :) Anyway it sounds like I am barking up the wrong tree. – Simon Doy Feb 5 '13 at 15:38

This is a network configuration issue, not a SharePoint issue. However, the problem is that most likely the VM is configured to use DHCP rather than a fixed IP address which means that while that original IP might have worked at the time the DNS entry was created, the VM no longer has that address. Either that or it was simply given the wrong IP when it was created.

  • Some kind of network issue does seem likely, but I was unsure if it could be Sharepoint specific. One of the first things I tried was changing the VM's IP to a static one. I'm using NAT on my VM host to give them network access, could that affect it? – Amicable Feb 5 '13 at 9:19
  • What IP address did you give the VM as a static IP? – Simon Doy Feb 5 '13 at 15:40
  • - the one in my CMD excerpt – Amicable Feb 5 '13 at 17:17

So it turns out the problem was to do with the way VMWare sets up NAT connections and runs that wizardry. Changing the VM network adaptor settings to "Bridged" allowed both services to communicate.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.